Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Answered And Solved Questions

Answered And Solved Questions A good place to check before you post your question. All answered / solved posts are archived here.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 19th April 2012
Junior Member
BS.Player Newbie
 
Join Date: Apr 2012
Posts: 6
Rep Power: 0
vortex87 is on a distinguished road
Default x264 problem

Hi.When I try to play video file which is with x264 codec and has high fps something like 59fps the audio is going out of sync.
I don't have that problem with Media player classic so it has to be some option in bsplayer.
Reply With Quote
  #2 (permalink)  
Old 20th April 2012
Ico-man's Avatar
BS.Support
BS.Player Power User
 
Join Date: Sep 2006
Location: Slovenia
Posts: 1,433
Rep Power: 10
Ico-man is on a distinguished road
Default

Can you send us a sample of the file to our FTP?

ftp.bsplayer.com
u: upload
p: h6fgcb2l
Reply With Quote
  #3 (permalink)  
Old 20th April 2012
Junior Member
BS.Player Newbie
 
Join Date: Apr 2012
Posts: 6
Rep Power: 0
vortex87 is on a distinguished road
Default

Sorry i didn't have a sample so i uploaded the full thing
Reply With Quote
  #4 (permalink)  
Old 23rd April 2012
Junior Member
BS.Player Newbie
 
Join Date: Apr 2012
Posts: 6
Rep Power: 0
vortex87 is on a distinguished road
Default

I noticed now that it show that the fps are 119 which is not true.It is 59fps
Reply With Quote
  #5 (permalink)  
Old 23rd April 2012
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 49
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

If your file is decoded by ffdshow then better enter ffdshow's option and disable post-processing. Same if it's Core AVC decoder.

BSplayer and MPC uses different decoders.

Usually, 59,94 fps is in 1920x1080 MPEG2 files not x264, as 2x29,97 fps is in interlaced files and not in progresive ones. So the file should be decoded by an MPEG2 decoder, not x264.

Can you PM me a link to such a file ?
I may be wrong.
Reply With Quote
  #6 (permalink)  
Old 23rd April 2012
Junior Member
BS.Player Newbie
 
Join Date: Apr 2012
Posts: 6
Rep Power: 0
vortex87 is on a distinguished road
Default

Tryed disable post-processing and it didn't work.

Last edited by vortex87; 23rd April 2012 at 05:20 PM.
Reply With Quote
  #7 (permalink)  
Old 23rd April 2012
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 49
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Downloading.
Meanwhile can you post here which filters are used to decode the file ?

LE: file plays ok in here, using CoreAVC, CoreAAC and Gabest MP4 splitter (same as MPC).
Reply With Quote
  #8 (permalink)  
Old 23rd April 2012
Junior Member
BS.Player Newbie
 
Join Date: Apr 2012
Posts: 6
Rep Power: 0
vortex87 is on a distinguished road
Default

ffdshow audio and video decoders ,haali media splitter
Reply With Quote
  #9 (permalink)  
Old 23rd April 2012
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 49
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Can you also post here CPU / RAM ?


LE: I would try to sugest you to swich from Haali to Gabest, see what's happening
Reply With Quote
  #10 (permalink)  
Old 23rd April 2012
Junior Member
BS.Player Newbie
 
Join Date: Apr 2012
Posts: 6
Rep Power: 0
vortex87 is on a distinguished road
Default

bsplayer is using 05 cpu and 94 740k ram
Reply With Quote
  #11 (permalink)  
Old 23rd April 2012
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 49
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

So, try to uninstall Haali. If you installed it through BSPlayer's codec manager, go to webteh folder in program files and run codecmanager.exe, select haali and uninstall it. If you installed it as standalone, just uninstall it.
Install Gabest MP4 splitter and see if it solves the problem.
Reply With Quote
Reply

Tags
x264

Thread Tools
Display Modes

Posting Rules

LinkBacks (?)
LinkBack to this Thread: http://forum.bsplayer.com/answered-solved-questions/16820-x264-problem.html
Posted By For Type Date
Medijski predvajalnik, predvajalnik filmov, YouTube predvajalnik, video predvajalnik, brezplačni predvajalnik, divx predvajalnik, zastonjski predvajalnik - BS.Player This thread Refback 5th May 2012 02:45 PM
Der Media Player, Movie Player, YouTube Player, Video Player, AVCHD Player, DivX Player, kostenlose Player - BS.Player.com This thread Refback 1st May 2012 06:55 AM

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with file path / can't open file / no message beholder4096 Bug Reports And Codecs 2 8th February 2011 03:28 AM
Problem with BSPlayer about brightness Lucas86 Bug Reports And Codecs 1 18th November 2008 05:52 PM
TV-picture "Zooming" in when in TV-mode problem :/ Dennis_Olof General Talk And Support 5 2nd January 2007 09:37 PM
WHY? Videos randomly jump - skip problem kimiraikkonen General Talk And Support 18 13th October 2006 06:53 PM
Quality problem during playback on TV (long) rakaz Feature Requests, Feedback And Suggestions 2 9th August 2002 10:59 AM


All times are GMT +1. The time now is 06:09 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19