Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Answered And Solved Questions

Answered And Solved Questions A good place to check before you post your question. All answered / solved posts are archived here.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 22nd October 2008
Junior Member
BS.Player Newbie
 
Join Date: Oct 2008
Posts: 2
Rep Power: 0
krapez is an unknown quantity at this point
Default Multiple audio tracks in one .avi file

Is it posible to select one of two audio tracks (languages) stored in one .avi video file? :?:
I have 2 audio tracks (esp and eng) and BS player selects spanish one by default. Why?
I'm using free version of BS player v. 2.32 running on WindowsXP sp3
Sasha
__________________
http://www.savan.info
Reply With Quote
  #2 (permalink)  
Old 22nd October 2008
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 26
BSPeter is on a distinguished road
Default

Could you please try as follows
(rightclick >) Options > Preferences
now keep [Shift]-key depressed and select "Filter management"
and then select (tick the box) "Use internal AVI parser"
Any change?
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #3 (permalink)  
Old 22nd October 2008
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 51
Posts: 5,127
Rep Power: 26
adicoto is on a distinguished road
Default

Yeas, you can. Ussualy, the streams are tagged wit :default: when muxed, so the player will select this track to be played by default.
So, open the file, rightclick -> audio -> audio streams and select there the one you want.
Reply With Quote
  #4 (permalink)  
Old 22nd October 2008
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 26
BSPeter is on a distinguished road
Default

You can change the default language under:
(rightclick >) Options > Preferences > Audio
(Default audio stream resp. language)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #5 (permalink)  
Old 24th October 2008
Junior Member
BS.Player Newbie
 
Join Date: Oct 2008
Posts: 2
Rep Power: 0
krapez is an unknown quantity at this point
Default

:D
Thanks it works fine now.
Thanks again. :D
__________________
http://www.savan.info
Reply With Quote
  #6 (permalink)  
Old 24th October 2008
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 26
BSPeter is on a distinguished road
Default

:D
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #7 (permalink)  
Old 7th April 2009
grendizer's Avatar
Senior Member
BS.Player Power User
 
Join Date: May 2005
Location: Europe
Posts: 144
Rep Power: 0
grendizer is an unknown quantity at this point
Cool

Hey I had the same problem and I just fixed it following BSPeter's advice.
but why is this menu "hidden"? Why do users need to press the shift key while clicking on "filter management" in order to get this option?
__________________
My codecs FAQ : http://www.davidsaber.com/resources/...sfaq/index.php
Reply With Quote
  #8 (permalink)  
Old 10th December 2012
Junior Member
BS.Player Newbie
 
Join Date: Dec 2012
Age: 45
Posts: 2
Rep Power: 0
czert2 is on a distinguished road
Default

Well, have much worse problem, when playing video with only one audio everthing ís ok, but once i try to play vide with two audio tracks, BS simply is unable to play it, it play no video, show 0 move lenght and only start/stop playing it. Sometiems its add blib blib sounds, but that all. Playing with settings, reintsaling Bs player + codecs dont help.
Didt have this problem in 2.61, but have it in 2.62 and 2.63. reverting back to 2.61 didnt helped too :(.
Reply With Quote
Reply

Tags
audio, avi, multiple, tracks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 09:44 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19