Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 10th November 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2005
Posts: 22
Rep Power: 0
Zatos is an unknown quantity at this point
Default Multiple bugs

There have been some bugs I have been experiencing with BSPlayer for a long time, and others which have been occurring across multiple versions. Here is a list:

1 - I believe since 2.58 beta that BSPlayer likes to crash at random, usually when I press the pause button on my remote, but not always. I thought this was just an issue with the beta, but the 2.58 final still does the same thing.

2 - The initial release of 2.57 had an issue with downloading subtitles in background, where it would always popup with the subtitle download window no matter what. This has not been completely fixed. Every once in a while, I get a popup window to select subtitles to download. It seems to happen only on certain shows I watch, if the subtitle for it is pretty recent (same day). Could just be a coincidence.

3 - This might have started with 2.58 beta. On occasion, BSPlayer will freeze/loop video whenever subtitles are currently being displayed on screen. I'm not sure why it happens on certain video files and others it doesn't. It looks very odd as it has several frames it plays within that time and jumps to another several frames. It keeps looping until the subtitle disappears... and then happens again the next time a subtitle appears.

4 - Button configurations randomly being assigned to #255. Every so often, BSPlayer will, for whatever reason, reassign a keyboard key association to #255. This has been happening for several years, since 2005 when I first got my remote. At that time I was using an ATI Remote Wonder 2. I have since switched to an ATI Remote Wonder (original). I have gone through multiple generations of hardware during that time, so the only thing that is the same as 2005 would be the remote. Although I am running on a different OS, the driver set is a bit different, and it isn't exactly the same remote(although the differences are minimal... and they probably use the same driver). I wonder if it is just something with remotes in general, as I'm not sure how many people use one. I have not been able to pinpoint anything in particular that would be causing it. Maybe when it crashes? I'm not even sure what #255 is, but whenever a key gets assigned that "button", it causes some of the other buttons on the remote to perform the function assigned to #255. It seems to only happen with play/pause/stop/next/previous (might have also happened with jump forward/back 10 secs). It might be safe to assume that it relates to the buttons I'm actually using on my remote.

5 - Ever since I upgraded to Win7 64 bit, there has been an issue with BSPlayer slowing down frames - I believe because of a memory issue. Basically, the video starts getting slightly choppy, say for instance going from 30 fps to 20-25fps. It can be remedied by closing other applications. However, it shouldn't be necessary to do that since there is always plenty of memory free when this happens. This also happens on my brother's computer as well, and started occurring at the same time - after upgrading to Win7 64 bit.

I am attaching a bug report for the crashes.
Attached Files
File Type: zip bugreport.zip (8.8 KB, 0 views)
Reply With Quote
  #2 (permalink)  
Old 19th November 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2005
Posts: 22
Rep Power: 0
Zatos is an unknown quantity at this point
Default

I think I have isolated the issue with the subtitles where it causes the video to stutter/loop.

It happens every time I have played an .mkv file. I don't know for certain if it happens with all mkv files, but I recently started using a lot more .mkv videos. It seems like this did happen a few times with .avi files, as that was before I was using .mkv except on rare occasions.
Reply With Quote
  #3 (permalink)  
Old 19th November 2011
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,162
Rep Power: 27
adicoto is on a distinguished road
Default

Concerning point 5. some other users report such behaviour on Win7 epecially on x64 version
crash after about 1h

As for the MKVs, we talk about ones with built in subtitles ?
Reply With Quote
  #4 (permalink)  
Old 20th November 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2005
Posts: 22
Rep Power: 0
Zatos is an unknown quantity at this point
Default

No, this is external subtitles, the ones that BSPlayer automatically downloads. Although it would be any external subtitle that does it.
Reply With Quote
Reply

Tags
multiple

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
BUGS in BSplayer v2.27.957 (Beta) Tizio Bug Reports And Codecs 1 11th February 2008 05:13 PM
BUGS in BS.Player v2.12.941 Tizio Bug Reports And Codecs 18 3rd March 2007 11:51 PM
BUGS in BSplayer v2.12.941 (Normal/Pro) Tizio Bug Reports And Codecs 0 5th October 2006 07:43 PM
cannot handle multiple selections(or multiple file names) ashish128 Bug Reports And Codecs 0 4th December 2003 05:58 PM
Multiple video streams without Ogg container edv General Talk And Support 0 26th January 2003 08:10 AM


All times are GMT +1. The time now is 07:31 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20