Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 29th January 2013
Junior Member
BS.Player Newbie
 
Join Date: Jan 2013
Age: 33
Posts: 3
Rep Power: 0
Ivanov is on a distinguished road
Default Bug with secondary UTF8 subtitles in MKV

Hi! Here is a bug report about secondary subtitles encoded in UTF8 in BSPlayer free version 2.63.1071 Oct 09, 2012.

I always watch movies with 2 subtitles (original and native ones). That’s why I like BSPlayer the most!)
This works fine if you have .avi with a number of .srt files. Moreover, it doesn’t matter whether these .srt files are saved in ANSI or in UTF8. It all works correctly.

But it doesn’t work if you have .mkv file. Like this one, for example:
Container: Matroska
ID 0: video (V_MPEG4/ISO/AVC)
ID 1: audio (A_AAC)
ID 2: audio (A_AAC)
ID 3: audio (A_AAC)
ID 4: subtitles (S_TEXT/UTF8)
ID 5: subtitles (S_TEXT/UTF8)
ID 6: subtitles (S_TEXT/UTF8)
ID 7: subtitles (S_TEXT/UTF8)

So, here are the steps to reproduce the bug:
– open any .mkv with UTF8 subtitles (this can be either built-in subtitles or separate .srt files – it doesn’t matter, there will be bug anyway)
– Subtitles > Primary > choose any subtitles
– it works correctly
– Subtitles > Secondary > choose any other subtitles
– and here is the bug:
— it can either crash (it just crashed and I sent you a bug report, dated 2013-01-29, 14:52:19, with the link to this very post in comments section)
— or it can show only one of those subtitles (the other subtitles don’t appear at all)
— or it can show the same subtitles both in lower part and in upper part of the screen

So, the only workaround I’ve found is to extract subtitles from MKV and resave them with ANSI encoding. Then it works fine. But it’s time consuming, so it would be great if this bug could be fixed!)

Here is some system info:
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120830-0333)
Language: Russian (Regional Setting: Russian)
System Manufacturer: Hewlett-Packard
System Model: HP Pavilion dv7 Notebook PC
BIOS: Default System BIOS
Processor: Intel(R) Core(TM) i5 CPU M 540 @ 2.53GHz (4 CPUs), ~2.5GHz
Memory: 4096MB RAM
Available OS Memory: 4022MB RAM
Page File: 6039MB used, 2004MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode
Card name: NVIDIA GeForce GT 230M
Manufacturer: NVIDIA
Chip type: GeForce GT 230M
DAC type: Integrated RAMDAC
Device Key: Enum\PCI\VEN_10DE&DEV_0A28&SUBSYS_365C103C&REV_A2
Display Memory: 2733 MB
Dedicated Memory: 978 MB
Shared Memory: 1755 MB
Current Mode: 1600 x 900 (32 bit) (60Hz)
Monitor Id: LGD0227
Native Mode: 1600 x 900(p) (60.080Hz)
Output Type: Internal
Reply With Quote
  #2 (permalink)  
Old 30th January 2013
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Using the old or the new subtitle engine ?
Reply With Quote
  #3 (permalink)  
Old 30th January 2013
Junior Member
BS.Player Newbie
 
Join Date: Jan 2013
Age: 33
Posts: 3
Rep Power: 0
Ivanov is on a distinguished road
Default

Yes, it’s new engine, in Options > Preferences > Subtitles > Subtitle Properties I have "Use new subtitle parser/renderer" selected.
Reply With Quote
  #4 (permalink)  
Old 30th January 2013
Junior Member
BS.Player Newbie
 
Join Date: Jan 2013
Age: 33
Posts: 3
Rep Power: 0
Ivanov is on a distinguished road
Default

Though, if I switch to the old engine, the bug remains. It doesn’t crash now, but it shows the same subtitles both in lower part and in upper part of the screen... If you choose other primary or secondary subtitles in UTF8 (in any language, English, Spanish or Russian), it doesn’t help: you still see the same subtitles both in lower and upper parts.
Reply With Quote
  #5 (permalink)  
Old 20th February 2013
DragonFighter's Avatar
Senior Member
BS.Player Power User
 
Join Date: Apr 2004
Location: Hellas
Age: 33
Posts: 195
Rep Power: 0
DragonFighter is an unknown quantity at this point
Default

I confirm that bug.
Also, if the mkv file has internal subtitles and you load or download external subtitles, then BSPlayer won't show the external subtitles and will crash if you select the internal subtitles again.
__________________
HWmaker
Please read BSPeter's Help2Help topic
Reply With Quote
Reply

Tags
mkv, secondary, subtitles, utf8

Thread Tools
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
[FIXED] How to disable secondary subtitles by default? aliado Subtitles 19 7th December 2010 12:44 AM
[FIXED] bs player bug - subtitles no longer being auto-found online eodeo Subtitles 14 9th August 2010 04:07 PM
Subtitles are not displayed - MKV file nekros Subtitles 4 16th June 2010 06:23 AM
MKV files & subtitles (Bug maybe) VampiricDeath Bug Reports And Codecs 3 26th May 2009 02:45 PM
Subtitles BSPeter General Talk And Support 0 23rd November 2002 02:16 PM


All times are GMT +1. The time now is 05:39 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19