Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23rd August 2003
Feñiz's Avatar
Member
BS.player Regular User
 
Join Date: Jun 2002
Location: Spain
Posts: 98
Rep Power: 0
Feñiz is on a distinguished road
Default Builds 500 and 501 Preferences bug

When I load a video, and I go to Options - Preferences, I get this error:

BSPlayer v0.86.501, Unhandled exception at EIP: 1C404136
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Access violation at address 1C404136 in module 'divxdec.ax'. Write of address 00000000
EAccessViolation
, 0x004CA61B, 0x004CA895, 0x004526D3, 0x00449D3E, 0x77E11D0A, 0x77E11BC8, 0x77E172B4, 0x004DDCB2, 0x77E9CA90
Bytes at EIP: 89 02 33 C0 C9 C2 08 00 8B F6 55 8B EC 81 45 08 40 FF

If I go to Options - Preferences WITHOUT loading a movie, it works.

And another little bug: When watching a movie at full screen, if I press a few times the "H" to hide/show the BSPlayer panel, a border appears at the top and the left of the video screen (it's like the "full screen window" moves and shows it border).
Reply With Quote
  #2 (permalink)  
Old 23rd August 2003
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Looks like an divx error. Options, preferencies, don't load divx settings. Is this enabled ?
Reply With Quote
  #3 (permalink)  
Old 23rd August 2003
cjdijk's Avatar
Member
BS.player Regular User
 
Join Date: Jul 2003
Location: Netherlands
Posts: 49
Rep Power: 0
cjdijk is an unknown quantity at this point
Default

Maybe you are using VobSub.
BSPlayer displays subtitles by itself.
VobSub does display subtitles too.
This is conflicting with each other.
A better alternative for VobSub is DivxG400.
This one is not active when using BSPlayer,
but does show subtitles when using Media Player.
So this is exactly what you need.
http://www.tac.ee/~prr/videoutils/divxg400.html
Reply With Quote
  #4 (permalink)  
Old 23rd August 2003
Feñiz's Avatar
Member
BS.player Regular User
 
Join Date: Jun 2002
Location: Spain
Posts: 98
Rep Power: 0
Feñiz is on a distinguished road
Default

No, I'm not using Vobsub. It's not installed on my computer.

I think it's because I'm using the new beta codec Kaukura, from DivX networks. In this codec, the interface for quality settings is changed from older versions (for example, 5.05). And I think BSPlayer tries to load those settings, and get an error. But this new interface from Kaukura will be used in new DivX versions, so BSPlayer must adapt to it.

I think it would be a good idea to remove the DivX 4 tab at options, because DivX codec options and settings are changing in every new version, and BSPlayer can fail every time you change the codec version. Also, you can adjust those options using the Propieties - DivX menu when playing a video.
Reply With Quote
  #5 (permalink)  
Old 23rd August 2003
Quietseb's Avatar
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Location: back in France...
Posts: 581
Rep Power: 0
Quietseb is an unknown quantity at this point
Default

Quote:
Originally Posted by cjdijk
A better alternative for VobSub is DivxG400.
This one is not active when using BSPlayer,
If I remember correctly, this is not quite exact.
depending on the overlay mode used by bsplayer, divxg400 will be trigerred or not.
[as for saying that divxg400 is better than vobsub :roll: let's say it's a matter of taste]

Quote:
Originally Posted by Fe?„iz
I think it's because I'm using the new beta codec Kaukura, from DivX networks
probably; there was the same type of problem when divx5.0.3 was released
Reply With Quote
  #6 (permalink)  
Old 23rd August 2003
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

It's 100% sure indeed caused by the version of 'divxdec.ax' which you're using. I've have had the very same problem and just replaced 'divxdec.ax' by another version and ..... no further problems!
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #7 (permalink)  
Old 23rd August 2003
Feñiz's Avatar
Member
BS.player Regular User
 
Join Date: Jun 2002
Location: Spain
Posts: 98
Rep Power: 0
Feñiz is on a distinguished road
Default

Quote:
Originally Posted by BSPeter
It's 100% sure indeed caused by the version of 'divxdec.ax' which you're using. I've have had the very same problem and just replaced 'divxdec.ax' by another version and ..... no further problems!
Yeah, but next versions of Divx will use the new interface, so when DivX 5.06 (or 6.0) will be released, all the people with the new version will get this error. This is why I think BST should fix it.
Reply With Quote
  #8 (permalink)  
Old 8th September 2003
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Quote:
Originally Posted by BSPeter
It's 100% sure indeed caused by the version of 'divxdec.ax' which you're using. I've have had the very same problem and just replaced 'divxdec.ax' by another version and ..... no further problems!
Look here for further info http://forum.bsplayer.org/viewtopic.php?p=6987#6987
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #9 (permalink)  
Old 8th September 2003
Feñiz's Avatar
Member
BS.player Regular User
 
Join Date: Jun 2002
Location: Spain
Posts: 98
Rep Power: 0
Feñiz is on a distinguished road
Default

This problem is solved in last nightly build (6-9-2003) ;). Now it works when using DivX 5.1.
Reply With Quote
Reply

Tags
500, 501, preferences

Thread Tools
Display Modes

Posting Rules


All times are GMT +1. The time now is 12:25 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19