Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 14th February 2004
Junior Member
BS.Player Newbie
 
Join Date: Feb 2004
Posts: 3
Rep Power: 0
Dario is an unknown quantity at this point
Default ERROR: Canvas does not allow drawing

BSPlayer keeps hanging up every time, giving the error "Canvas does not allow drawing". I installed builds 800, 803, 804 and 805 and the error doesn't go away.
My system is a Pentium 3 @ 1.1 GHz, 256 MB RAM, ASUS Cuple-VM Motherboard, GeForce2 MX 400 64MB PCI, Windows 98 Second Edition, DirectX 9.0b.
I tried BSPlayer in another partition with Win98 and DirectX 7 previously and thought that reinstalling Win98 (this time SE) with the lastest drivers would solve this problem. Using the onboard VGA doesn't help neither, so I don't think this is a video driver problem. Windows Media Player, Zoom Player and RadLight work fine.
The problem appears when I click over the full screen image to visualize the user interface and it does not appear to be happening when I turn the SUBTITLES off.

Thx.
Dario
Reply With Quote
  #2 (permalink)  
Old 17th February 2004
Junior Member
BS.Player Newbie
 
Join Date: Feb 2004
Posts: 1
Rep Power: 0
Olga is an unknown quantity at this point
Default Re: ERROR: Canvas does not allow drawing

I've the same problem but unfortunatelly still cannot solve it. Maybe the problem is in codecs?

If you know how to escape from this I'll be glad to hear from you
Olga
Reply With Quote
  #3 (permalink)  
Old 17th February 2004
Member
BS.player Regular User
 
Join Date: Jan 2003
Location: Greece
Posts: 48
Rep Power: 0
Sonickydon is an unknown quantity at this point
Default

I used to get that problem some times but not anymore..i'm not a coder or something but if you guys also have an asus motherboard AND you use the asus monitor utility you might skip the problem by shuting it down..seems that the 1+ versions of the player are using heaps of resources and the system can't handle it or that there's some interaction problem of the player and the asus utility .. at least my system which is based on a 600mhz pentium can't run both of them without problems.. while there's no problem when i use the player without running the asus utility in the backround.. i can't be 100% sure that it will work for you but i've seen that error message from other apllications as well and not only bsplayer ,so i take a wild guess here..
system config : 600mhz pIII,768mb RAM,voodoo3500TV 16mb video card,winME, DirectX9.0b,bsplayer 1.805-overlay mode 1 -disabled yv12 format,,ffdshow20030523(subtitles handled by bsplayer and not by ffdshow)
I hope it helps :)
Reply With Quote
  #4 (permalink)  
Old 17th February 2004
Member
BS.player Regular User
 
Join Date: Jan 2003
Location: Greece
Posts: 48
Rep Power: 0
Sonickydon is an unknown quantity at this point
Default

I forgot to mention my asus p3b-f motherboard -may the gods of upgrades bless me ASAP ! :D :D
Reply With Quote
  #5 (permalink)  
Old 18th February 2004
Junior Member
BS.player Regular User
 
Join Date: Mar 2003
Location: Czech
Posts: 14
Rep Power: 0
plas is an unknown quantity at this point
Default

Quote:
Originally Posted by Sonickydon
seems that the 1+ versions of the player are using heaps of resources
seems that BSplayer does not release resources at all. After a few minutes it takes all resources. Because Windows 98 doesn't have unlimited resources, it will show error messages.
It is better if the option "Draw subtitles to overlay surface" is checked.
Reply With Quote
  #6 (permalink)  
Old 18th February 2004
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 28
BSPeter is on a distinguished road
Default

@Dario
Could you please mention which options are selected under Options > Precerences > Video and also under Subtitles ?
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #7 (permalink)  
Old 24th February 2004
Junior Member
BS.Player Newbie
 
Join Date: Feb 2004
Posts: 4
Rep Power: 0
pistesil is an unknown quantity at this point
Default .

I have the same problem.
Reply With Quote
  #8 (permalink)  
Old 25th February 2004
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 28
BSPeter is on a distinguished road
Default

And I still have the same question
(Also: did you already try a different setting of mode/overlay/VMR under Options > Preferences > Video ?)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #9 (permalink)  
Old 25th February 2004
Junior Member
BS.Player Newbie
 
Join Date: Jul 2003
Posts: 2
Rep Power: 0
pila is an unknown quantity at this point
Default I have the same problem with 805 but not 803

I use 803 and it works well. But, when I tried to install 805, this error wold not let me see anything. So I can not even enter it to try to change any settings.

I use subtitles, Win98se, IBM notebook with plenty of memory
Reply With Quote
  #10 (permalink)  
Old 25th February 2004
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 28
BSPeter is on a distinguished road
Default Re: I have the same problem with 805 but not 803

Quote:
Originally Posted by pila
I use 803 and it works well. But, when I tried to install 805, this error wold not let me see anything. So I can not even enter it to try to change any settings.
If "this error" indeed is "ERROR: Canvas does not allow drawing" you should be able to change settings as this error only occurs if a movie is played.
So start-up BSPlayer itself (i.e. NOT by double-clicking or similar on a movie-file, but by clicking on (a link to) bsplay.exe).
Then rightclick on BSPlayer's skin (control panel) > Options > Preferences > Video.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #11 (permalink)  
Old 28th February 2004
Junior Member
BS.Player Newbie
 
Join Date: Feb 2004
Posts: 4
Rep Power: 0
pistesil is an unknown quantity at this point
Default settings

HI
I`m using win98 and Version 1.00 RC1 Build 805 released.
my video settings are:
remember pan-scan, remember movie window size,wait for vertical blank, disable yv12format, use overlay mode1.
and the subtitles are:
use outline font, use anti-aliased font, transparent background, auto resize font, auto load.
Thank you.
Reply With Quote
  #12 (permalink)  
Old 29th February 2004
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 28
BSPeter is on a distinguished road
Default

Please first check if your problems are over in the newest release (build 806).
(Go to download page via main page)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #13 (permalink)  
Old 3rd March 2004
Junior Member
BS.Player Newbie
 
Join Date: Jul 2003
Posts: 2
Rep Power: 0
pila is an unknown quantity at this point
Default

yes, 806 works for me :D
Reply With Quote
  #14 (permalink)  
Old 6th March 2004
Junior Member
BS.Player Newbie
 
Join Date: Feb 2004
Posts: 3
Rep Power: 0
Dario is an unknown quantity at this point
Default

Sorry about the delay, I was on my vacation. The video and subtitiles preferences I use to have were the default ones. Tried the three overlay options with no success. After I saw the new 807 build and the comment about this error, I uninstalled the previous version and installed the last build. So far I didn't see this problem anymore. The one I detect is that BSPlayer insist to try to register the default file type associated every time I enter the preferences menu. I choose "Select none" but when started again the default video files are automatically set again. Not as irritating as the Cavas error though.

Thanks a lot!.
Dario
Reply With Quote
Reply

Tags
canvas, drawing

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 03:57 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20