Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 14th September 2004
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 24
Tizio will become famous soon enough
Default Build 812 issues

Great work!! :D All the posted bugs seems to be disappeared and almost all translations are supported..

Little bug:
-The menu item "Advanced" (Options->Filters->Advanced) can't be updated by changing the language at runtime, only if the player is restarted.

Not working translations:
-Section [WID34]
-In Load Subtitles Common Dialog: Subtitles ([Strings]->item #79)

Missing translations:
-OPEN FILE DIALOG (from Menu/Key & from Playlist):
All files
Media files

-BROWSE FOR FOLDER DIALOG (from Playlist)
Recurse subdirectories

-PLAYLIST
"Add URL" window

-LOAD FROM FILE DIALOG (from Playlist)
Playlist

-SAVE TO FILE DIALOG (from Playlist)
BSplayer playlist

-SAVE TO FILE (RELATIVE PATHS) DIALOG (from Playlist)
BSplayer playlist

-EQUALIZER
Preamp

-EXPORT AS CHAPTERS DIALOG (Edit Bookmarks)
BSplayer chapters

-VIDEO INFO WINDOW
Video
Audio 1
Audio 2 (?????)

-FILTERS WINDOW (?????)
...

Thank you and bye!! :)
Reply With Quote
  #2 (permalink)  
Old 14th September 2004
Member
BS.player Regular User
 
Join Date: Nov 2003
Location: Saint Petersburg \ Syktyvkar, Russia
Age: 36
Posts: 65
Rep Power: 0
MRAc is an unknown quantity at this point
Default

BSPlayer 1.02 - is really GREAT! :)
Big Thanks for this build - all critical bugs are fixed :) I'm really happy!

And found 2 little bugs.
1) When enablig tuner in BSPlayer, sound appears in 5-6 seconds later. When I opening "Capture configuration" - sound desappeares in 5-6 sec again. TV Tuner Configuration has option Video standart, but it locked in PAL-D, so I have only Black&White picture. If I choosing in Country section "Russia, SECAM-D (7)" - picture become color. But when I click OK, and in next window also OK - it became B&W again.
Maybe it is bugs of WDM-Driver of my tuner (FlyPrime34FM on Philips 7134 decoder, LifeView 2.1.5.0 Driver[old, but very stable]), I don't know...

2) After watching tuner, if I click "Open" and choose any video file - its not playing. I must choose "Close file" first, and then "Open"

Oh, found another bug :\ In "Sony"-skin (my favourite) not working Full-screen skin :( It appeared only if I choosing another skin, and then "Sony" again.
__________________
Russian translations of BS.Player here: http://mrac.nnz-home.net/bsprus.html
Reply With Quote
  #3 (permalink)  
Old 14th September 2004
Junior Member
BS.player Regular User
 
Join Date: Jul 2003
Posts: 17
Rep Power: 0
januzi is an unknown quantity at this point
Default

I watched http://www.energyradio.fm/content/ballmer.asx, after all I clicked on x and got very nice exception error (not in BSPlayer window, but in Windows Exception Box). Strange.
Reply With Quote
  #4 (permalink)  
Old 14th September 2004
LSDSkunk's Avatar
Senior Member
BS.Player Power User
 
Join Date: Jun 2004
Location: Sweden
Posts: 109
Rep Power: 0
LSDSkunk is an unknown quantity at this point
Default

When you are watching a movie in window mode and click on another window that covers the whole screen, the bsplayer main window does not go away, it's still on top.
Reply With Quote
  #5 (permalink)  
Old 16th September 2004
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 24
Tizio will become famous soon enough
Default

Two missing translations:
-ABOUT WINDOW
"Icons Created by"
The word "by" between language and author: [Lang_Name] by [Author]
Reply With Quote
  #6 (permalink)  
Old 16th September 2004
LSDSkunk's Avatar
Senior Member
BS.Player Power User
 
Join Date: Jun 2004
Location: Sweden
Posts: 109
Rep Power: 0
LSDSkunk is an unknown quantity at this point
Default

Quote:
Originally Posted by Tizio
Two missing translations:
-ABOUT WINDOW
"Icons Created by"
The word "by" between language and author: [Lang_Name] by [Author]
I don't see how that's a bug?
Reply With Quote
  #7 (permalink)  
Old 16th September 2004
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 24
Tizio will become famous soon enough
Default

@LSDSkunk:

Indeed I wrote "missing translations", not "bugs" and in the post title I wrote "issues" and not "bugs"...

I'm a translator of BSplayer and those translations are missing, so I think BSP should be awared of it. :)

Here there's a bug:
While resizing the playlist window, if you try to move the left/top side from left/top to right/down, the window, once reaced the minimum size, starts moving in that direction...

Bye!
Reply With Quote
  #8 (permalink)  
Old 18th September 2004
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 1
Rep Power: 0
pbkg is an unknown quantity at this point
Default

I have run into a "bug" with sending messages to the window. If I have 22 Matroska files (DivX 5.2 + bug fix + MP3 Audio), and send a couple of messages telling it to jump to the next file, before it has had a chance to load the file properly, it will crash (no response, no CPU usage). At the same time, if I do it with AVI files (same setup as above, different content though), it will work fine, just to run it straight though.

Attached to this post should be a zip file containing a DLL, and a VBScript file that shows the above. You will need to register the DLL first (regsvr32 BSPlayerUICE.DLL).

This is what is done when calling next (MSVC 6.0 as a COM DLL).
Code:
	AFX_MANAGE_STATE(AfxGetStaticModuleState())

	HWND bsp_hand;
	bsp_hand=FindWindow("BSPlayer",NULL);
	SendMessage(bsp_hand,WM_BSP_CMD,BSP_Next,0);
This was tested on 1.0, 1.01 and 1.02 now, and although the handling has improved (in 1.0 it crashed even with AVI files, in 1.01+ it seems to work find (unless of course you add about 10 bs.next calls in the VBS file).

Secondly, this is more of a feature requet, but I am just going to through it in here anyways, but I would like to be able to go from the first item in the playlist, back round to the end of playlist by hitting the previous button? Possible? Impossible? It would just make it easier, rather than having to go though 22 times (because it is easier for me to load all 22 files at once through UICE), to get to the last couple of files.
Attached Files
File Type: zip crash-bs.zip (8.1 KB, 103 views)
Reply With Quote
  #9 (permalink)  
Old 19th September 2004
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 2
Rep Power: 0
mR_nEo is an unknown quantity at this point
Default Not able to set this build as a default player

I have found another bug. I dont know if its doing the same thing in Pro version, but in basic version does.
Im not able to get this built as a default player for my AVIs. I tried doing that in BSP option and also in windows settings. Nothing works :/. Previous version had no such problems.
Ive tried this on two computers. My own and at work. Both with the same result.
Reply With Quote
  #10 (permalink)  
Old 20th September 2004
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 24
Tizio will become famous soon enough
Default

@mR_nEo
Hi! Did you try to select the option "Register extensions on player start"?
I have free and pro versions and I can associate extensions without any problem :? .
Try, otherwise I don't know how to fix your problem, maybe there's really a bug :(

Bye!
Reply With Quote
  #11 (permalink)  
Old 22nd September 2004
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 2
Rep Power: 0
mR_nEo is an unknown quantity at this point
Default

Tizio: sure I did. Its realy strange. After a few days, I was able to set BSP as default player for AVIs, but not for MPGs. Realy strange. Im sure, that system reinstalation would solve it, but I would rather prefer another way of solution ;). Anyway, its not that big problem that I would stop using BSP because of it :).
Reply With Quote
  #12 (permalink)  
Old 22nd September 2004
LSDSkunk's Avatar
Senior Member
BS.Player Power User
 
Join Date: Jun 2004
Location: Sweden
Posts: 109
Rep Power: 0
LSDSkunk is an unknown quantity at this point
Default

Quote:
Originally Posted by mR_nEo
Tizio: sure I did. Its realy strange. After a few days, I was able to set BSP as default player for AVIs, but not for MPGs. Realy strange. Im sure, that system reinstalation would solve it, but I would rather prefer another way of solution ;). Anyway, its not that big problem that I would stop using BSP because of it :).
Try opening Windows Media Player and un-check all filetypes in the options. Did the trick for me. :?
Reply With Quote
Reply

Tags
812, issues

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 10:35 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20