Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 23rd September 2004
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 2
Rep Power: 0
Aurelius is an unknown quantity at this point
Default Subtitles in AVI container

I posted this in "General discussions" but since no one is able to answer and I suppose it might as wll be a bug (I'm not sure though) I allow myself to post it here as well with the hope of resolving this matter. Thanks again.

Posted: Fri May 28, 2004 2:15 pm Post subject: Subtitles in AVI container - stream names

--------------------------------------------------------------------------------

Hi,
thanks a lot for the free BSplayer that supports subtitles multiplexed in AVI container (with AVI-Mux GUI). But opposite to the audio streams, where the names are shown correctly by BSplayer when I want to switch the stream beeing played, the subtitles only show Sub 1, Sub 2, etc. option.

Can someone please let me know what I am doing wrong? I believe that I name the sub streams correctly in the AVI-Mux GUI as well as the audio streams which work all right.

Thank you.
Reply With Quote
  #2 (permalink)  
Old 26th September 2004
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 2
Rep Power: 0
Aurelius is an unknown quantity at this point
Default

Now, after I had chat on some other forums and did a lot of testing, I really do believe that this is a bug. In MKV files the player reads the language name and code for the audio streams from the file correctly and shows them in the right-click menu
"Audio/Audio streams" as: <name> <(Language)>, and for the subtitle streams it shows it in the right-click menu "Subtitles" as <(Language)>.

But in AVI file, the player will only show the names of the audio streams but will not (read?) and show the names of the subtitle (SRT) stream. It only shows the blank line(s) in the menu, according to the quantity of SRT streams in the file.

Will you consider fixing this issue, as your player is the only one that can parse and show SRT subs multiplexed in the AVI container. So it is a real pity. As well, it would be nice to enable reading/showing the stream name for the subs in MKV and not only the lang. code generated name. You might not be aware of the fact that in many movies you need to be able to distinguish 2 or more streams of the same language. Like a movie in a native lang. when some Japs talk with forced subs, and then the whole subs for yourself when you decide to play the picture in another lang. since your friends from France or Germany just arrived. Not to mention the directors cut etc.

Thanks for this player. It still is my favorite for the rel. small size, effectivnes, ease of use and availability.
Reply With Quote
Reply

Tags
avi, container, subtitles

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 06:20 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20