Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 15th January 2013
Junior Member
BS.Player Newbie
 
Join Date: Apr 2010
Posts: 8
Rep Power: 0
deepset is on a distinguished road
Default No Audio on any files

I am using Pro version 2.57. I was watching a movie and skipped thru some boring section when the player had an error and had to close. Ever since then no video has any sound.

Any other program (i.e. Window Media Player, Media Player Classic) work perfect, just not BS.Player

I have uninstalled and reinstalled 2.57. Installed the Free newest version, and still no audio. I reinstalled my 2.57 version.

I have uninstalled all the codec that the manager updates, and reinstalled them.

When i am playing a video and go to audio > audio streams.. depending on the movie it will say English [undetermined], or GPAC ISO Audio Handler [undetermined], or nothing at all.

Can someone please lead me to an answer, this one has stumped me and i miss my BS.Player.
Reply With Quote
  #2 (permalink)  
Old 15th January 2013
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 49
Posts: 5,122
Rep Power: 25
adicoto is on a distinguished road
Default

Usually this happens when the audio slider is reset to zero (mute).
If you are using Win7, also check in audio mixer that BSPlayer's volume isn't muted also.
Reply With Quote
  #3 (permalink)  
Old 15th January 2013
Junior Member
BS.Player Newbie
 
Join Date: Apr 2010
Posts: 8
Rep Power: 0
deepset is on a distinguished road
Default No Audio on any files

Nothing is muted.. i checked. Like i said, Window Media Player has sound, and everything else does too. Its like BS.Player is not able to decode the audio part of the video files. Or does not recognize that the video has audio. That is why i reinstalled all the codecs. But still no audio.

When everything was working fine, double click on a video file and it starts.

Now, double click on a video file, and there is about 3 seconds of dead time, and it might even restart the file before the video starts to show with no audio. Does not matter the file i try this on, i have tried hundreds of different files and formats.
Reply With Quote
  #4 (permalink)  
Old 16th January 2013
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Could you post the filters/codecs actually used by BS.Player for playback?
With a file loaded: rightclick > Options > Filters > Advanced
Make sure to also click on Source and on the +signs shown in front of the codecs/filters shown, which will reveal further info (and access).
Of course especially any audio related (and splitter) are of interest.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #5 (permalink)  
Old 16th January 2013
Junior Member
BS.Player Newbie
 
Join Date: Apr 2010
Posts: 8
Rep Power: 0
deepset is on a distinguished road
Default No Audio in any file

Ok, First Random Movie

AsyncClock
Default DirectSound Device
- Audio Renderer
- Advanced
Video Mixing Renderer
- Quality
AC3Filter
- Main
- Mixer
- Gains
- Equalizer
- SPDIF
- System
- About
ffdshow Video Decoder
- ffdshow
ffdshow Audio Decoder
- ffdshow audio
AVI Splitter
Source


Second Random Show

Default DirectSound Device
- Audio Renderer
- Advanced
AsyncClock
Video Mixing Renderer
- quality
AC3Filter
- Main
- Mixer
- Gains
- Equalizer
- SPDIF
- System
- About
ffdshow Video Decoder
- ffdshow
Microsoft DTV-DVD Audio Decoder
Source
- About
- Options


Hope this is what you wanted.... lots of info on each of those, too much to type
Reply With Quote
  #6 (permalink)  
Old 16th January 2013
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 49
Posts: 5,122
Rep Power: 25
adicoto is on a distinguished road
Default

So, BSPlayer recognize the audio stream in the video files. Did you also checked in Equaliser settings it it's not muted ?
Reply With Quote
  #7 (permalink)  
Old 16th January 2013
Junior Member
BS.Player Newbie
 
Join Date: Apr 2010
Posts: 8
Rep Power: 0
deepset is on a distinguished road
Default No audio in files

Nothing is muted.

Its more like whatever BS.Player uses to read the video files is corrupted. It still recognizes the Video portion of the files, but not the Audio. But it is not something that was fixed by Uninstalling and Reinstalling any of the Filters or BS.Player itself.

Everything was working fine till BS.Player had an error, now nothing i do fixes it. And if it logged that error, it is long gone with the Uninstalling/Reinstalling.
Reply With Quote
  #8 (permalink)  
Old 17th January 2013
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 49
Posts: 5,122
Rep Power: 25
adicoto is on a distinguished road
Default

My last advice. Uninstall BSPlayer. Go to c:\users\yourusername\app data\roaming and delete BSPlayer folders. Reinstall BSPlayer.
Reply With Quote
  #9 (permalink)  
Old 17th January 2013
Junior Member
BS.Player Newbie
 
Join Date: Apr 2010
Posts: 8
Rep Power: 0
deepset is on a distinguished road
Default No audio any file

I have done that at least 3 times before even posting here. Uninstalling all the codec's, local and system, and deleted the empty folders. Updated all the codec's to newest versions and made sure only system was available so i did not have 2 versions. Even went into Regedit and deleted BS.Player stuff there, prior to reinstalling.

It kills me that Windows Media Player and Media Player Classic work perfect while BS.Player does not. Something only BS.Player uses is corrupted and I have no idea how to figure out what that is. Its just not accessing the files properly, then sending bad info to the codecs so no audio is being processed, but somehow the video shows.

If the new version had fixed this, i would have bought another license, but not even that worked. So i am stuck with Windows Media Player and Media Player Classic as my main viewers now, and I hate them both.
Reply With Quote
  #10 (permalink)  
Old 24th January 2013
Ico-man's Avatar
BS.Support
BS.Player Power User
 
Join Date: Sep 2006
Location: Slovenia
Posts: 1,425
Rep Power: 10
Ico-man is on a distinguished road
Default

Filters>Default DirectSound device>tab Advanced>if value for Fulness is changing, you probably have mute enabled somewhere.
Reply With Quote
  #11 (permalink)  
Old 25th January 2013
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Peculiar that in the examples given both AC3 Filter AND ffdshow Audio Decoder respectively Microsoft DTV-DVD Audio Decoder appear to be used.
I cannot remember having ever seen that combination under XP (probably still also deepset's OS?).
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #12 (permalink)  
Old 25th January 2013
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 49
Posts: 5,122
Rep Power: 25
adicoto is on a distinguished road
Default

AC3Filter is just a filter, it's not a codec. It cannot decode by itself audio streams other than AC3. All of others are first decoded by a codec and afterwards processed by AC3Filter. Play an MPEG2 audio file, it will use Microsoft DTV-DVD Audio Decoder as codec, play an MP3 file it will use MP3 decoder DMO (or similar) as codec, play an AAC file, it wil use CoreAAC or similar codec, DTS files will use DTSac3source........
Or ffdshow audio if installed.
Reply With Quote
  #13 (permalink)  
Old 25th January 2013
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Nice. Like I said "I cannot remember having ever seen that combination".
According to AC3Filter's info it decodes AC3/DTS and MPEG Audio Layer I/II formats, whereas it also encodes AC3 to output any multichannel source to SPDIF. So possibly in the examples given AC3Filter is used as encoder for SPDIF output? Could you, deepset, please enlighten us on this? And if so, isn't there a chain of used filters shown on AC3Filters' SPDIF-tab? (And what is selected in BS.Player under Preferences > Audio > Output?)

@deepset: AC3Filter seems to be the common denominator in the examples given by you, so I personally would search further in that direction (or in BS.Player's Audio settings). P.S.: Did you already check as suggested by Ico-man?
Quote:
Originally Posted by Ico-man View Post
Filters > Default DirectSound device > tab Advanced
If value for Fulness is changing, you probably have mute enabled somewhere.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #14 (permalink)  
Old 1st February 2013
Junior Member
BS.Player Newbie
 
Join Date: Apr 2010
Posts: 8
Rep Power: 0
deepset is on a distinguished road
Default Somehow Fixed

I do not know what changed. I deleted the folder in Program files. Copied a working version from my other computer to this one and still had the exact same problem. So I deleted it and then decided to try something else so i restored the first one from the trash folder and now everything works fine.

I deleted and reinstalled everything at least 7 times with no change, and this finally fixed it. Wish i knew what the problem really was.

Thanks for all the help and sorry for the slow reply.. thought i was forgotten about.
Reply With Quote
Reply

Tags
audio, files

Thread Tools
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bug playing ogg files with multiple audio streams (1.0 803) LeQuack Bug Reports And Codecs 6 29th November 2003 01:42 PM


All times are GMT +1. The time now is 11:37 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19