Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Subtitles

Subtitles Post question about BS.Player and subtitles (srt sub ssa mkv) here

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11th June 2010
Junior Member
BS.Player Newbie
 
Join Date: Sep 2009
Age: 38
Posts: 6
Rep Power: 0
Marillion is on a distinguished road
Default Spanish subtitles does not displayed correctly

Please explain me how to turn on the support of Spanish subs in BSPlayer.

I have Russian version of Windows, and subtitles in Cyrillic and standart Latinic fonts is showing correctly, but in Spanish subs specific symbols are used that not have been shown correctly.

I have BSPlayer version 2.53.

Options->Preferences->Subtitles->Font->Symbols->Western European is not working.

Last edited by Marillion; 11th June 2010 at 05:57 PM.
Reply With Quote
  #2 (permalink)  
Old 11th June 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Opciones > Preferencias > Subtítulos [Propiedades de Subtítulos]
Click on [Fuente]
Опции > Настройки > Субтитры [Настройки субтитров]
Click on [Шрифт]
Now select a standard font like e.g. Ariel or Verdana or Times New Roman
(Do not select "Symbol"-font! Leave Script on "Western European".)
Do other applications (like e.g. notepad/wordpad or any wordprocessor) properly show Spanish texts?

(You may have to do this separately for [Primary subtitles] and [Secondary subtitles].)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #3 (permalink)  
Old 12th June 2010
Junior Member
BS.Player Newbie
 
Join Date: Sep 2009
Age: 38
Posts: 6
Rep Power: 0
Marillion is on a distinguished road
Default

Quote:
Originally Posted by BSPeter View Post
Opciones > Preferencias > Subtítulos [Propiedades de Subtítulos]
Click on [Fuente]
Опции > Настройки > Субтитры [Настройки субтитров]
Click on [Шрифт]
Now select a standard font like e.g. Ariel or Verdana or Times New Roman
(Do not select "Symbol"-font! Leave Script on "Western European".)
Thank you, but unfortunately it's not working. My standart font is Arial, and i didn't change it. In order of experiment i tried to change it on 'Times New Roman' font - no good result.

Quote:
Originally Posted by BSPeter View Post
Do other applications (like e.g. notepad/wordpad or any wordprocessor) properly show Spanish texts?
Spanish subtitles propely shown in 'Notepad2' when i select source encoding for subtitles as 'Western European (ISO-8859-1)'. All Spanish subs that i downloaded from subtitles bases on Internet were in that encoding.

I also tried to re-encode subtitles to 'Western European (Windows-1252)' encoding, but it's also not gives a good result, and some symbols spoil during re-encoding (so it becomes to impossible to make reverse encoding).

In standart Notepad, Wordpad, MS Word (russian versions) and also in Subtitles Workshop spanish subtitles are not shown properly, with standard font and 'Western' script.

Last edited by Marillion; 12th June 2010 at 11:08 PM.
Reply With Quote
  #4 (permalink)  
Old 13th June 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

What Windows-version (XP-Vista-7) do you run?

P.S.:
In your Character Map you don't have these?
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #5 (permalink)  
Old 13th June 2010
Junior Member
BS.Player Newbie
 
Join Date: Sep 2009
Age: 38
Posts: 6
Rep Power: 0
Marillion is on a distinguished road
Default

Quote:
Originally Posted by BSPeter View Post
What Windows-version (XP-Vista-7) do you run?
Windows XP SP3.

Quote:
Originally Posted by BSPeter View Post
P.S.:
In your Character Map you don't have these?
Yes, i have all needed symbols.

At the end, i could solve my problem by encoding source subtitles from code page 'Western European (ISO-8859-1)' to the code page 'UTF-8 with signature' (simple UTF-8 code page has not worked).

Is this only exceptionally right way to display subtitles like Spanish properly in BSPlayer? Just 'UTF-8 with signature' code page is supported by BSPlayer for these types of subtitles?
Reply With Quote
  #6 (permalink)  
Old 13th June 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Just a wild idea: do you happen to also have Ariel Unicode MS font?
If you select that in BS.Player?
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #7 (permalink)  
Old 13th June 2010
Junior Member
BS.Player Newbie
 
Join Date: Sep 2009
Age: 38
Posts: 6
Rep Power: 0
Marillion is on a distinguished road
Default

Quote:
Originally Posted by BSPeter View Post
Just a wild idea: do you happen to also have Ariel Unicode MS font?
I you select that in BS.Player?

I don't have that font in BSPlayer, but i tried Lucida Console Unicode font, it's not shown properly in non-'UTF-8 with signature' code page.
Reply With Quote
  #8 (permalink)  
Old 13th June 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Quote:
Originally Posted by Marillion View Post
I don't have that font in BSPlayer ...
BS.Player simply uses Windows' fonts. So if you don't have Ariel Unicode MS in BS.Player, you also don't have Ariel Unicode MS installed in Windows.

PS: check your pm
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #9 (permalink)  
Old 14th June 2010
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 49
Posts: 5,122
Rep Power: 25
adicoto is on a distinguished road
Default

To have full support, you must tell windows that you want that support, so go to control panel, regional settings and add spanish as supported language (in non-unicode page too)
Reply With Quote
  #10 (permalink)  
Old 18th September 2010
Junior Member
BS.Player Newbie
 
Join Date: Sep 2010
Posts: 1
Rep Power: 0
roccomp is on a distinguished road
Default

I have a similar problem:
Using Spanish subs, all the vowels with "tilde - ´ " are changed to crazy symbols.
Tried many common fonts already, like Arial, Times etc.

I am using XP sp3 and BS Pro v.2.27
Any solution?
Thanks
Reply With Quote
  #11 (permalink)  
Old 18th September 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Frequently asked questions - BS.Player wiki
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #12 (permalink)  
Old 2nd January 2011
Junior Member
BS.Player Newbie
 
Join Date: Jan 2011
Age: 38
Posts: 2
Rep Power: 0
Renato Rocha is on a distinguished road
Default

It didn't work to me. =[

Subs works fine untill i do any change to the line after that í becomes Ã-other symbols accentuation symbols change too.
Reply With Quote
  #13 (permalink)  
Old 2nd January 2011
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

@Renato_Rocha:
This occurs when you're using subtitle-editor of Pro-version?
Which BS.Player version/build-number?
Could you try if (de)selecting "Use new subtitle parser/renderer" under
(rightclick >) Options > Preferences > Subtitles [Subtitle properties]
makes any difference?
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #14 (permalink)  
Old 2nd January 2011
Junior Member
BS.Player Newbie
 
Join Date: Jan 2011
Age: 38
Posts: 2
Rep Power: 0
Renato Rocha is on a distinguished road
Default

@BsPeter

Thanks for the quick answer. I'm a portuguese speaker and although i consider my english pretty good i would never imagine this would resolve it.

My subtitles seems to work now. But i did it by selecting "Use new subtitle parser/renderer" (it was already unselected). I use BS. Player Pro v.2.57 build 1051 under Windows 7.

Thanks.
Reply With Quote
Reply

Tags
correctly, displayed, spanish, subtitles

Thread Tools
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
Subtitles are not displayed - MKV file nekros Subtitles 4 16th June 2010 06:23 AM
No subtitles displayed on X64 Server2008 nemo12 Subtitles 4 6th June 2010 10:51 PM
Spanish subtitles buggaboo Bug Reports And Codecs 0 29th April 2005 09:30 AM
Spanish subtitles not displayed propertly Seimour Feature Requests, Feedback And Suggestions 1 6th May 2003 03:58 PM
Subtitles BSPeter General Talk And Support 0 23rd November 2002 02:16 PM


All times are GMT +1. The time now is 10:16 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19