Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Subtitles

Subtitles Post question about BS.Player and subtitles (srt sub ssa mkv) here

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 21st April 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2005
Posts: 22
Rep Power: 0
Zatos is an unknown quantity at this point
Default Subtitles no longer downloading

I am not sure what happened, but BS.Player will no longer download online subtitles. It always says it is checking for subtitles and then immediately says there are none found.

I checked everything in the settings, and everything is set up correctly. I made sure I could access the subtitle pages from my web browser, and they work.

The last subtitle downloaded was on 4-3-2011, although I don't really know if that means anything. There is nothing that was changed on my computer on that date, although I installed Windows 7 64bit SP1 on 3-31. It still shows that it was downloading subtitles after that, like I had mentioned, until 4-3.

I emptied the subtitle folder just in case as it was getting rather large.

I am using 2.56.1043. I would upgrade, but since I use subtitles and there are known bugs with subtitles on the current version, I refuse to use a newer version until an update is released. It is highly annoying having to close a window every time I play a new video - especially when considering I watch it on my tv away from my computer. (Hope that doesn't sound bitter, I do love BSPlayer and I'm not harping here - it's a great product)

To me it seems like it just is not being able to access the subtitle servers, for whatever reason. I tried playing around a little bit with options - setting to different default language as well as checking on and off different servers. I also tried unchecking to download subtitles in background to see if it would give me a list - still no.

Any help is much appreciated.

I love my subtitles.
Reply With Quote
  #2 (permalink)  
Old 22nd April 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2005
Posts: 22
Rep Power: 0
Zatos is an unknown quantity at this point
Default

I didn't mention it, but some obvious other things I tried:

Restarted computer
Complete uninstall (using Revo Uninstaller) and reinstall

Interesting to note, there are three subtitle files in my subtitles folder now, for 2 different files. However, it still comes up with the message 'no subtitles found' and the subtitle files are 0 bytes. Strangely, when I replay these video files they will sometimes check for subtitles for a while as if though it is downloading them, but then says no subtitles found and creates the file. The other half of the time it is just coming up with 'no subtitles found' instantly.

Edit:

I've discovered more. If I turn off the option to download subtitles automatically, it will give me the list of subtitles, which will download if I choose to. But it will act like it can't find any when it is set to automatically download subtitles, when it clearly is. On repeated attempts, it seems like now it is usually trying to download the subtitles, but for some reason it doesn't download properly and ends up as a 0 byte file.

I tried the newest version and it has the same problem. This is very odd, I have used the new version before as well as 2.56.1043 and never had this problem. It must be something else affecting BSPlayer or causing BSPlayer to have issues. What? I have no idea.

Last edited by Zatos; 22nd April 2011 at 08:46 AM.
Reply With Quote
  #3 (permalink)  
Old 27th April 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2005
Posts: 22
Rep Power: 0
Zatos is an unknown quantity at this point
Default

Well, this is disappointing. If nobody knows how to fix it, perhaps someone might know of another way for automatic subtitle downloads?
Reply With Quote
  #4 (permalink)  
Old 25th May 2011
Junior Member
BS.Player Newbie
 
Join Date: Mar 2011
Age: 27
Posts: 2
Rep Power: 0
KoenC is on a distinguished road
Default

Having exactly the same problem for quite a while now...it's quite annoying indeed, and the BS Player dev team remains silent about this aswell
Reply With Quote
  #5 (permalink)  
Old 3rd June 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2005
Posts: 22
Rep Power: 0
Zatos is an unknown quantity at this point
Default

Well, although I am saddened someone else is having the problem, I am also glad that I am not alone.

I really like BSPlayer, but it is apparent there is zero support. There is a known issue I reported over 6 months ago - which was confirmed - and still no update has been released. It should be such a simple fix too. The newest version always pops up with the download subtitles box instead of downloading in the background. Which is irrelevant now considering that subtitles don't want to work anyway. So, I've been using an older version because they won't release a new update.

I have used BSPlayer for several years, pretty much exclusively. But these sorts of things make me want to find something else. If I do find another video player that is halfway decent with automatic subtitle downloading, I might just switch and not look back, sorry to say.
Reply With Quote
  #6 (permalink)  
Old 3rd June 2011
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 49
Posts: 5,122
Rep Power: 25
adicoto is on a distinguished road
Default

With all due respect, bug it's not confirmed, just another user states it have the same issue. I can't reproduce any of the things mentioned above, subtitle downloading function working great. If somebody on the support team confirm your report, then it's a confirmed bug.

My ideea, as you installed Windows 7, is that you don't have UAC disabled and even if subtitles are found, BSPlayer can't save the file on your PC as it does not have the right to write files.

As for the fact that sometimes "no subtitle found" pop ups imediately, in my case this is caused by a bad internet connection (usually) and more, sometimes subtitles providers change the way the database it's handled and until an update come up, subtitles can't be found any more.
Reply With Quote
  #7 (permalink)  
Old 3rd June 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2005
Posts: 22
Rep Power: 0
Zatos is an unknown quantity at this point
Default

The bug being confirmed I mentioned was not this particular issue. It was a separate issue and was confirmed back in December.

It can't be UAC as it worked for a while, then just stopped working for reasons undetermined. Running as administrator doesn't seem to help, either.

I could definitely see this being something that might have changed on the subtitle provider's end, but going such a long time without an update makes it frustrating. I live for the subtitles!
Reply With Quote
  #8 (permalink)  
Old 9th June 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2005
Posts: 22
Rep Power: 0
Zatos is an unknown quantity at this point
Default

Good news. Installing the 2.58 Beta update helped to fix this problem. It did not outright fix it, but if I uncheck the 'opensubtitles' and 'getsubtitles' as online subtitle providers - and just leave the bsplayer server - it will work. YES!

First thing it did before I unchecked those was once again act like it was downloading and then created a 0 byte sub file. This suggests to me that it must be something that has changed on the back end.

I hope it continues to work. Even though I'm not deaf or hard of hearing - my comprehension goes way up when I have subtitles.

Finally, thanks for the update guys. I haven't been able to find another video player that has all the features I like about BSPlayer.
Reply With Quote
Reply

Tags
downloading, longer, subtitles

Thread Tools
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
[CONFIRMED] 2.57 bug - subtitles no longer download automatically runkzfis Bug Reports And Codecs 5 10th December 2010 01:07 PM
[FIXED] bs player bug - subtitles no longer being auto-found online eodeo Subtitles 14 9th August 2010 04:07 PM
able to autoload subtitles - but not show them? themolester Feature Requests, Feedback And Suggestions 0 26th June 2008 09:28 AM
Testing subtitles, overlays and filters. Wormlord1442 Bug Reports And Codecs 0 5th February 2004 07:07 PM
Subtitles BSPeter General Talk And Support 0 23rd November 2002 02:16 PM


All times are GMT +1. The time now is 10:11 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19