Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 15th September 2003
Junior Member
BS.Player Newbie
 
Join Date: Sep 2003
Posts: 1
Rep Power: 0
hoffmane is an unknown quantity at this point
Default Tip for overlay problems

"overlay failed" warning
I struggled with overlay problems for a while. When I first installed BSPlayer it worked fine, then at some point something changed and I couldnt get the overlays to work properly. I read quite a few messages on this board as well as the faq without finding a fix. I started to suspect some kind of directx issue (electricsheep screensaver stopped working as well). I updated directx and the problems remained, HOWEVER, when I went into the diagnostics program, directdraw was disabled. No clue how this happened. So here's my fix, hopefully it'll help someone.

Start -> Run -> "dxdiag"
Click "Display" tab
Make sure directdraw acceleration is enabled.
(Direct 3d was disabled for me as well. I enabled it but I can't imagine it would matter for divx)

I found this fix here:
http://spt1.intervideo.com/php/searchnext.php?pid=262

There are some other tips that might help someone with bsplayer overlay problems on that page.

Maybe it would be good to include this info in the faq..... ?
Reply With Quote
  #2 (permalink)  
Old 17th September 2003
Junior Member
BS.Player Newbie
 
Join Date: Sep 2003
Posts: 7
Rep Power: 0
fedhman is an unknown quantity at this point
Default another overlay problem !

Hi everybody !
I'm quite a rookie so let me explain the situation .

every time i launch bsplayer, i've got the warning message "overlay failed" and then, bsplayer only display the sound of the avi file.... I checked with gspot and i've got all the codecs for this file...

I read the tip of the previous message and , i check dxdiag to see what kind of problem i can have : so , directx 9.0b is installed and the only problem reported from dxdiag is that AGP is not available and there is no hardware acceleration interface for direct 3D 8+. I'm told to verify a new driver for my graphic card.

So i check on the matrox site (i've got quite an old card : MGA Mystique) and i cannot find a newer driver fot it....

Is this the reason of the overlay warning ? coz before installing ACE mega Codecs Pack, i can use the windows media player to display my avi file, but only in the smallest size... Now, i cannot anymore , i've got the sound and green bars instead of the video !!!! :(((

i installed bsplayer, coz i read that it is the best player for slow processor like mine ( PII 266)...

Can someone help me ????

fedhman kassad from hyperion
Reply With Quote
  #3 (permalink)  
Old 17th September 2003
Junior Member
BS.player Regular User
 
Join Date: Jun 2003
Posts: 20
Rep Power: 0
Katharsis is an unknown quantity at this point
Default re: help! overlay failed

Quote:
Hi everybody !
I'm quite a rookie so let me explain the situation .
every time i launch bsplayer, i've got the warning message "overlay failed" and then, bsplayer only display the sound of the avi file.... I checked with gspot and i've got all the codecs for this file...

Lower your resolution first to 800*600 then to 640*480
Lower your desktop colors count to 16bit depth, if it doesn't work then to 256 colors
Lower your display refresh frequency to 60hz.

You not only have a slow PC, you also have a graphics card with 8mb or less. After doing one or all three of these BSplay should work in overlay.

If you use 256 colors and want to use subtitles, make sure you set in BSplayer preferences to display subtitles in overlay.


Katharsis
Reply With Quote
  #4 (permalink)  
Old 17th September 2003
Junior Member
BS.Player Newbie
 
Join Date: Sep 2003
Posts: 7
Rep Power: 0
fedhman is an unknown quantity at this point
Default

Thx 4 the really quick answer !
I'm gonna try this tips right now, and i'm back to tell you about ! ;)
Reply With Quote
  #5 (permalink)  
Old 17th September 2003
Junior Member
BS.Player Newbie
 
Join Date: Sep 2003
Posts: 7
Rep Power: 0
fedhman is an unknown quantity at this point
Default hun, hun......

hmmm.... sorry, but it did not work....

though,I just don't understand why i should change the display settings for bsplayer coz it used to work in media player (till i make the last install....)

so, do you got some other tricks in your bag for me ? please ?
Reply With Quote
  #6 (permalink)  
Old 17th September 2003
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,158
Rep Power: 27
adicoto is on a distinguished road
Default

On a 266 P II you'll never play a decent divx or xvid movie. Even with WMPlayer.
The video information is loaded into video card memory. If the quantity of information is greater than the videocard memory you get an "overlay failed" message. WMP don't use overlay.
Green bars you can get from xvid movie using an older codec. Go to www.xvid.net and download from there xvid 0.9.2
Reply With Quote
  #7 (permalink)  
Old 17th September 2003
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default Re: another overlay problem ! / Slow computer or poor video?

Quote:
Originally Posted by fedhman
i installed bsplayer, coz i read that it is the best player for slow processor like mine ( PII 266)... Can someone help me ????
Does this post perhaps contain anything which works for you?
slow computer or poor videocard playback??
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #8 (permalink)  
Old 18th September 2003
Junior Member
BS.Player Newbie
 
Join Date: Sep 2003
Posts: 7
Rep Power: 0
fedhman is an unknown quantity at this point
Default

thx adicoto for the info ! i know now what does mean this %*$#ing message "overlay failed" and why WMP (used to) played the avi file !

i've just downloaded the xvid codec you told me about and i will see (well i hope so ...)

just one more question : why WMP display correctly (but really smally ) the movie before i install sld and ace codec ? Is this coz the codec of the file are too old and have been replaced ? coz i don't understand why GSpot tell me that the rendering is OK (3 video and 2 audio codecs installed for the avi file...)

And yes , i know i 've got an antic ( antique ?) computer but i've got it for free so ..... anyway i planned to buy a real one !!!!

so thx again all of you and excuse my english , coz i'm from the country of the freedom fries ;) !!!!

fedhman kassad from hyperion
Reply With Quote
  #9 (permalink)  
Old 18th September 2003
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,158
Rep Power: 27
adicoto is on a distinguished road
Default

So, about codecs. Try not to use codec packs. They are well intended but usually do more bad than good.
BSPlayer and WMP can resize the movie window, use drag'n'drop.
WMP don't use the same codecs as BSPlayer on some file types.
Not so sure that free means also good. Sometimes you must pay for a good thing, and a free thing can do more wrong.
Reply With Quote
  #10 (permalink)  
Old 18th September 2003
Junior Member
BS.Player Newbie
 
Join Date: Sep 2003
Posts: 7
Rep Power: 0
fedhman is an unknown quantity at this point
Default

ok adicoto ! i've got the message ! but you know , it's just a computer that my lil'bro let me because he bought a good stuff for his job... so....

for the codec pack, i read on the emule-france site , that to use bsplayer you've got to dl sld codec pack.....

by the way bspeter , i use your link and i try (once again) the tip of Katharsis with the resolution switched to 640x480/256 colors but i still have the overlay failed warning message and moreover, i 've got "display hardware is not capable of color-space conersions.Switching to RGB" !!!

so i guess my hardware is simply too bad to play decently videos.... it's such a shame ..... !!!

once more : thx to all of you for trying to help me !

fedhman kassad from hyperion
Reply With Quote
  #11 (permalink)  
Old 18th September 2003
Junior Member
BS.Player Newbie
 
Join Date: Apr 2003
Posts: 5
Rep Power: 0
blurpnroll is an unknown quantity at this point
Default attn:fehdman

Hey, I had too this overlay failed problem. If you're running the latest build and have installed DirectX9 you could try enabling Use VMR-9 in the Video options, and changing the Overlay Mode. This helped for me. good luck!

aloha, Steve and Danno
blurp'n'roll
Reply With Quote
  #12 (permalink)  
Old 18th September 2003
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,158
Rep Power: 27
adicoto is on a distinguished road
Default

I get to manage a P1@166 without MMX to play an MPEG 1 file using overlay at 800x600@256 colours on an S3 trio 64V+ with 2MB. Maybe your problem is somwhere elde.
Reply With Quote
  #13 (permalink)  
Old 19th September 2003
Junior Member
BS.Player Newbie
 
Join Date: Sep 2003
Posts: 7
Rep Power: 0
fedhman is an unknown quantity at this point
Default

ok ....
i think i've got the key of the problem : the matrox mystique (plain , not G200) DO NOT feature the overlay !!!!!
i found it on (when the link is ok) :
http://www.trends.in-sync.com/online...Card_Table.htm

adicoto: your last post make me feel pretty much down : the crappy card i've got is almost the only one which doesn't allow bsplayer to work !

if anyone got more info on this card (upgrades, drivers or so on...) , let me know about !


fedhman kassad from hyperion
Reply With Quote
  #14 (permalink)  
Old 19th September 2003
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,158
Rep Power: 27
adicoto is on a distinguished road
Default

If yoi have a PII@233 it is very possible to have an AGP slot. An riva tnt2 videocard is about 25-30 $. I have one of this and I never hade any problem with it playing movies. Hope you know what i mean.
Reply With Quote
  #15 (permalink)  
Old 20th September 2003
Junior Member
BS.Player Newbie
 
Join Date: Sep 2003
Posts: 7
Rep Power: 0
fedhman is an unknown quantity at this point
Default

yep ! i got it ! ;)
my next post will be about how great bsplayer is !!!!
Reply With Quote
Reply

Tags
overlay, tip

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 05:37 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20