Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 22nd January 2005
Junior Member
BS.Player Newbie
 
Join Date: Jan 2005
Posts: 4
Rep Power: 0
Shimekiri is an unknown quantity at this point
Default srt problems

I have many movies that will not display subtitles. I have BSPlayer pro v1.02, build 812.14.

I have tried multiple subtitles for these movies (Korean and Japanese) and none will play.

How can get the subs to play? Is there a program that can check the subs to make sure they are formatted correctly?

Thank you.
Reply With Quote
  #2 (permalink)  
Old 22nd January 2005
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

It is not entirely clear to me what you mean.
Therefore I may be telling you "old news". In case I do, please don't shoot me.
A subrip (.srt) subtitle-file can be loaded manually after having loaded the video-file, by a right-click followed by selection of "Load subtitles" ...etc. (Most skins also have a button for this.)
However, if a subtitle-file is placed in the same folder as the movie-file and has the same name as the movie (except for the file-extension of course), you need not do so, as it will then load automatically (unless you've disabled subtitles under (rightclick >) Options > Preferences > Subtitles.
You could perhaps check if a file is correctly formatted by loading .srt file in a subtitle-utility like Vladimir's SubSync. Just run it; click on [..]-button at the right of the "subtitle"-box and in the window then opening change filetype from "SAMI files *.smi" to "SubRip files (*.srt)" and browse to your subtitle to Open it. Subsequently simply save it (change the filename to be sure).
You could perhaps also read this post to which I would add that you can e.g. create Ini/Bsi files (with multiple language subs) using HWMaker.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #3 (permalink)  
Old 25th January 2005
Junior Member
BS.Player Newbie
 
Join Date: Jan 2005
Posts: 4
Rep Power: 0
Shimekiri is an unknown quantity at this point
Default

Thanks for responding Peter.

I'll use Spygirl as an example.

I have Spygirl CD1.avi and Spygirl CD1.srt in the same directory.

BSPlayer doesn't automatically play the subs for some reason.
It also doesn't play them when I choose them by Loading Subtitles.
It's a problem I have with half of my movies. Some movies run the subs with no problem.

I've downloaded Subsync. The Subsync player reads and displays the subs just fine. VLC does the same (but screws up the audio).

I just can't get the appropriate subs to display. I've checked the x/y positions, auto and manually positiioned them. etc... This isn't a problem I've had with BSPlayer and as it's my favorite media playing app I'd like to figure it out rather than use something else.

Thanks again for your help.
Reply With Quote
  #4 (permalink)  
Old 25th January 2005
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

If subtitles are correctly loaded (either automatically or manually) most skins (control panel) will show the name of the subtitle-file.
E.g. with base-skin it should be shown just above "Movie size:".
(Edit: please note that the above info is no longer valid for version 2 base-skin)
If filename is shown there, BSPlayer has recognized it (and able to play).
Further: what is setting under
(rightclick >) Options > Preferences > Video > [Video rendering]
Try a different mode; e.g. no overlay or "Use overlay Mode 1".
Any difference?
Maybe you could check (with movie loaded) under
(rightclick >) Options > Filters > Advanced
what codec/filter is actually used to show your movie.
Is that different for the movies that do show subtitles compared to those that don't?
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #5 (permalink)  
Old 25th January 2005
Junior Member
BS.Player Newbie
 
Join Date: Jan 2005
Posts: 4
Rep Power: 0
Shimekiri is an unknown quantity at this point
Default

Great info.

The ones that won't play subs are XViD. Every other one is DivX.
Reply With Quote
  #6 (permalink)  
Old 25th January 2005
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

What happens if you let DivX codec also deal with XviD encoded movie ("Support Generic Mpeg-4" selected / See second part of item 4 of my Help2Help post)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #7 (permalink)  
Old 25th January 2005
Junior Member
BS.Player Newbie
 
Join Date: Jan 2005
Posts: 4
Rep Power: 0
Shimekiri is an unknown quantity at this point
Default

We have a winner.

I had to download the most current DivX and XviD codecs, then followed your suggestion and all the subs are playing perfectly with 'Support Generic Mpeg-4" selected.

Arigato gozaimasu and many humble thanks for your time and patience Peter. I'd write you a comment card if this was a restaraunt :P
Reply With Quote
  #8 (permalink)  
Old 25th January 2005
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

(I don't think you actually needed XviD, because if you select "Support Generic Mpeg-4" under DivX's settings, the DivX codec will also decode XviD-encoded movies; you can check that in BSPlayer under "Filters" with an XviD movie loaded.)
However: Glad that it worked out (and "If it ain't broke, don't fix it", or in other words: I would now leave it "as is").
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
Reply

Tags
srt

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 10:14 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20