Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Closed Thread
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 28th July 2007
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default BS.Player 2.2x bugs re GUI/translation

Re: version 2.2x builds 95x/96x (If fixed this is mentioned and text will be in small grey characters)
This post was SUCCEEDED by this one on 15 August 2008
This is a summary of the bugs I found in BS.Player's GUI/translation:
(Added 29 Feb 08:)
Possible message at start-up:
"Please download updated version from www·bsplayer·com" (not in language file)
Main window
___In "DVD mode" hovering over [T][C][S][L] results in English-only menu names shown (skin issue)
___In "Audio mode" ditto for "Shuffle"
___Edit Aug 02, 2007: both above issues fixed in version 2.23 build 953
__If either VIDEO- or DVD- or AUDIO-mode was selected before selecting either RADIO- or TV-mode,
__then the previous VIDEO/DVD/AUDIO-specific menu-options don't hide (slide back in). (skin issue)
__(Added 26 Dec 07:) Also the skin's Radio and TV tags remain the same as if they were not selected.
About F1 Edit Feb 10, 2008: below issues fixed in build 957 of Feb 6th
___Translation missing of "Icons created by" and of "by" for each language in the rolling list
___(as well as of "version" and "build" and the date at top).
___Also "Registered to..." should imho be centred
___(any text longer than the English original is shown 'at the right')
Also
___Example: (not possible using rightclick-menu, but) by using [menu]-button on Base-skin
___e.g. the about-window can be opened more than once
___(note this is similar for any other menu-option which is already opened).
___Closing of such (second) menu-window then results in an English BS.Player-error-report
__(plus "Continue"-, "Send error report"-, "Close"-buttons).
__(Added 10 Feb 08:) [Build+date] should imho be centred.<=Edit May 5, 2008: issue fixed in build 963
__month-abbreviations are not in language-file (alternatively replace by month-number?)
Open DVD in (right-click) menu
___Selecting > Open DVD... opens a submenu titled (in bar at top) "Choose drive" (untranslated)
___also [Cancel]-button remains untranslated, as well as ....
___Edit Aug 02, 2007: both above issues fixed in version 2.23 build 953
___... untranslated, as well as ....[OK]-button
___(Note I don't mention that last issue anywhere else as OK seems a universally known expression;
___however for e.g. cyrillic, greek, arabic, hebrew, or several "far-east charactersets"
___a translation of "OK" could/would (nevertheless) be appropriate anyhow?)
Open URL in (right-click) menu (Added 14 Feb 08:)Edit 21-04-08: fixed in Beta 200804202231
___The "report-message" "Parsing URL" remains untranslated (not in language file)
Title & Chapters in (right-click) menu
___Title 1 ... (etc) resp. Chapter 1 ... (etc) remain untranslated.
___Edit Aug 02, 2007: fixed in version 2.23 build 953
Bookmarks in (right-click) menu
___Title ... Chapter ... (etc) remain untranslated.
___Edit Aug 02, 2007: fixed in version 2.23 build 953 (by simply omitting "title" resp. "chapter")
Subtitles in (right-click) menu (Added 14 March 08:)Edit 21-04-08: fixed in Beta 200804202231
___"Primary", "Secondary" and their submenus remain untranslated. (build 200803140930)
___Ditto for Beta 200803191845. This also concerns previously correctly working translations!
Preferences > General > [File types]
___(Added 10 March 08:) Space for "Custom icon" unnecessarily too narrow for some languages.
___Edit March 14, 2008: fixed in version 2.28 beta
Preferences > Video ... [General] respectively ... [OSD] Edit Feb 10, 2008: below issues fixed in build 957 of Feb 6th
___"Main window alpha value" - "Video window alpha value" - "Alpha blending value (VMR9 only)"
__The first two use a scale of 5-100, whereas the last uses a scale 0-1.0
__Suggest to also use a scale till 100 for the last one (or adapt the scale for the first two).
Preferences > Video ... [General] Edit Feb 10, 2008: below issue fixed in build 957 of Feb 6th
___More appropiate place for "Main window alpha value" imho would in "Skins" section of Preferences
Preferences > Video ... [General]
___Last checkbox inactive (and still "attached" to [WID10] C1_10 & C1_10H of language file)
___(Made appropriate remarks in [WID10] of Dutch language file)
___Edit Dec 26, 2007: in v.2.26 language file text for [WID10] C1_10 must be changed/added to read "Allow video window off screen"
Preferences > Video ... [Video rendering] (Added 25 March 08:)Edit 21-04-08: partially fixed in Beta 200804202231
__Several Error/Warning-messages remain untranslated (not in language file); e.g.:
___Internal video rendering RGB may result in: "Warning / Unknown file format (XVID)"
___(Funny: unknown, but XVID) clicking OK -> movie plays in ActiveMovie Window)
__Internal video rendering RGB 'Overlay': "Error / Please close movie first"
___Edit 5 May 2008: "No RGB Overlays supported"
___When trying to select EVR (for Vista) in XP:
___"Error / Enhanced Video Renderer(EVR) is not available on this system.
___Make sure you have DirectX 9+ installed and latest video drivers."
Preferences > Subtitles (Added 14 March 08 for Beta 228 200803140930)
___No translations for "Primary subtitles" and "Secondary subtitles"Edit 5 May 2008: fixed
Preferences > Media library
___When activating button [Optimize database] both "action-" and "ready-" message are in English
___Edit Aug 02, 2007: fixed in version 2.23 build 953
Preferences > Filtermanagement with [Shift]-key depressed Edit Feb 10, 2008: below issue fixed in build 957 of Feb 6th
___No translation for "Internal filters" and "Use internal AVI parser" (not in language file)
__(Added 10 Feb 08:) Space for translation of "Use intern...." too restricted. Must be wider.
Equalizer
___Translation of "Center" (of balance) doesn't work with Base version 2.x skin (it works for v1.x skin)
___Edit Aug 02, 2007: fixed in version 2.23 build 953
Media Library
__(1) "Fixed" (hardcoded/graphics) text at south-west above logo: "SELECTED"
__(2) If empty: "report/warning" in English (center of window)
__(3) "Title" "Artist" "Album" at top and "Add" at bottom"
__(2) switch permanently (=as long as ML remains active) back to English when selecting a playlist
__(4) Selecting Add playlist > Add new playlist opens an English-only submenu
__(5) In "Audio mode" rightclick at bottom (below line "Search") opens an English-only submenu
__(6) Bottom-part of "Audio mode"-window also shown when in "Radio-mode"
__(7) Space for labels at bottom too narrow
___(8) When using +Add in "Radio/TV/Podcast-modes" the pop-up submenus are English-only
___(9) When adding files using +Drive (or +Folder) report window (Added ...) is English-only
__(10) When adding an URL the messages "Error" or "Downloading podcast info" are English-only
___(11) [Cancel] button for +Drive window is English-only
___(12) Ditto for [Close] button of rightclick > ID3 tags-submenu
___(13) Rightclick in a blank space at left under "Playlists" opens an English-only submenu (+ subsubmenu)
___[color=#A2A2A2](14) The "report" when clicking on (e.g.) a radiostation in the list (i.e."Parsing URL ...") is English-only<=Edit May 5, 2008: fixed
[size=2]Playlist (new style) Edit Feb. 14, 2007: fixed
___In rightclick menu the line "Load from media library" untranslated (not in language file)
___In submenu of Add URL [Cancel]-button untranslated
__(Added 14 Feb 08:) "Report" following Add URL "Parsing URL" is English only (not in language file) [also valid for old style playlist]
Playlist (old style) (Added for v.2.26.956) Edit Feb 10, 2008: issue fixed in build 957 of Feb 6th
___Just opening it (provided it holds a file) results in an error (English only "error-option-menu")
__(By the way: the error report/menu appears to be a new and realy nice and improved version!)
___(Added 12 Feb 08:) Minimize-button of old-style-playlist doesn't work. Edit 21-04-08: fixed in Beta 200804202231
___(Added 21 Mar 08:) With media library active just opening playlist old style causes an error. Edit 21-04-08: fixed in Beta 200804202231
Subtitle editor
__Title "Subtitle" in bar at top (Start/Stop/Subtitle) not translated
Audio > Audio Streams in (right-click) menu
___The two options at bottom, i.e. "Play all" and "Choose..." remain untranslated
___Edit Nov 17, 2007: fixed


(The remaining "except" and "buts" of my post in which I reported bugs found in version 2.20 build 950 are now (i.e. Aug.02) included in this post)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
  #2 (permalink)  
Old 26th July 2008
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 51
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

Missing translations in "missing codec or incomplete downloaded file" window.

"Unable to play media file"

"BS.Player cannot play the media file.
You don't have necessary codec installed, file may damaged or not media file."

"Click 'Find codec' to try to find codec."

"When checking for codec also send the file header"
Closed Thread

Tags
22x, gui or translation

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 01:19 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20