Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 5th February 2010
Junior Member
BS.Player Newbie
 
Join Date: Feb 2010
Posts: 6
Rep Power: 0
mikeggsm is on a distinguished road
Default [SOLVED] jpg screen capture problems in EVR

I just downloaded BSPlayer (Free) for screen captures and I have two problems:

1) capture "what you see" saves the first capture I made over and over after I change locations (the time parameter %T reflects the new location but the image saved keeps being the first one I made).

2) capture "original image size" works but there is always a column of "garbade" on the left, aomething like 32 or 16 pixels wide. It's not really garbage, it's the right side of the screen which wraps itself on the left, so the whole image is shifted to the right.

Thanks for any help.
Reply With Quote
  #2 (permalink)  
Old 7th February 2010
Junior Member
BS.Player Newbie
 
Join Date: Feb 2010
Posts: 6
Rep Power: 0
mikeggsm is on a distinguished road
Default

Anyone?

Not using "capture what you see" is OK, I'll use "capture original size". But I would really like captures to be clean, without a garbage column on the side.

By the way the column is actually on the right, copied from the left side, and interestingly it only happens when the image format of the captures is JPG, if I choose BMP the captures are clean.

Could anyone take a few seconds to make a test capture?

Thanks.
Reply With Quote
  #3 (permalink)  
Old 10th February 2010
Junior Member
BS.player Regular User
 
Join Date: Jan 2008
Posts: 13
Rep Power: 0
garren is an unknown quantity at this point
Default

hello,

I had the same problem as him here. I'm using Windows 7 here, K-Lite Mega Codec Pack 5.70 installed, with my BS.Player Pro 2.51 Build 1022, been set to Enhanced Video Renderer (EVR) as my video rendering. the video playback is almost perfect and smooth for my old Pentium 4 PC here and i'm really glad about it. But there's only one problem here, and that is about image capture.

Here's the problem details:

1-When i was watching the movie in fullscreen mode, i press 'P' for "Capture original image size" feature, the image quality is great, but there's a long vertical line column at the right side of the snapshot taken which would make the picture that i capture look weird. (Look at the picture below)


2-The size of the image when i capture WHILE in fullscreen mode is not in its original image size even though i pressed only 'P'. for example, the video resolution is 1280 x 720, when i capture it while in fullscreen mode, it'll became 1680 x 945. just look at the pic above (this is almost as my desktop resolution 1680 x 1050 -_- )

3-Although i can try to capture the image in its original size, it is not very precise unfortunately, for example, the original size is 1280 x 720, when i capture it while NOT in fullscreen mode, it'll became 1266 x 712 which is a little bit smaller than the original size. And the vertical line column at the right side of the picture is still there. >_<


EDIT: regarding problem number (3), the picture size is not so precise when being captured, i SOLVED it by turning off the 'borderless play window' option. i usually make it borderless while playing movie in BS.Player, never thought that it could make the capture size been slightly smaller.

I hope in the later updates, BS.Player could fix all these problems for EVR rendering. I really love BS.Player with EVR rendering, and i really hope it could be fix soon. :)

P.S - These problem is still there even when i tested with my old windows XP SP2/3 so i dont think its OS related problem here.

Last edited by garren; 13th February 2010 at 05:23 PM.
Reply With Quote
  #4 (permalink)  
Old 10th February 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

Sorry, I personally cannot reproduce. (XP SP3 - Nvidia)
(Neither different imagesizes, nor such narrow (few pixels wide) column from the left on the right-hand side either)

mikeggsm: re "what you see": Frequently asked questions - BS.Player wiki
mikeggsm & darren: It might be interesting to know what videocards (and drivers) you're using.
darren: Of course both 1280 x 720 resp. 1680 x 945 are ratio 16:9 exactly, whereas your desktop resolution of 1680 x 1050 is 16:10 ratio.
(Trying to find an 'explanation' for 1266x712, I also tried if videowindow with a border or a borderless window made a difference to the effect it perhaps 'stole' a few pixels; ...but it didn't. So ???..confuzzled !)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #5 (permalink)  
Old 10th February 2010
Junior Member
BS.player Regular User
 
Join Date: Jan 2008
Posts: 13
Rep Power: 0
garren is an unknown quantity at this point
Default

Thanks for the reply! okay, i'm using Radeon X1650 AGP here (quite old one eh?), with its driver provided by windows 7 update. yeah 1680 x 945 is 16:9 in ratio, but it would be a bit much hassle to have to resize them manually and thats why i brought this problem up. >_< it only happen in EVR renderer only, if im using the default overlay, capturing image while in fullscreen mode did not result in desktop resolution but with the original size of the image.

And, does the line column on the right side of the snapshot i kept seeing have something to do with graphics card? o.o it's quite annoying to see it. i tried with other renderer for solution, but i found out that only EVR and Internal Renderer Overlay (default) is the best (most smooth) for my old PC here. I would love to stick with the default Overlay but, you know, it always clash with windows 7 aero and keep turn it back to basic theme when playing movies. thats why if the problem can be fixed, it would be much appreciated. :)

thank you very much for your assistance anyway! ;)
Reply With Quote
  #6 (permalink)  
Old 10th February 2010
Junior Member
BS.Player Newbie
 
Join Date: Feb 2010
Posts: 6
Rep Power: 0
mikeggsm is on a distinguished road
Default

BSPeter: Thanks. You can't reproduce the problem because it only happens with the EVR video renderer. VMR9 screenshots don't show the right column garbage but, with VMR9, under Windows 7 the video is pixelated in full screen.

I have a Radeon 4670, I used the Windows default drivers, updated to the newest drivers from ATI to try to solve this problem, it didn't change anything.

Again, the strangest thing is that if the screenshots are taken in BMP instead of JPG (Options -> Frame and thumbnail capture -> image format = BMP), the right column garbage disappears...

PS: the garbage column is on the right just like in garren's screenshots, not on the left as I wrote in my first message.
Reply With Quote
  #7 (permalink)  
Old 10th February 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

Quote:
Originally Posted by mikeggsm View Post
...You can't reproduce the problem because it only happens with the EVR video renderer...
Quote:
Originally Posted by garren View Post
...P.S - These problem is still there even when i tested with my old windows XP SP2/3 so i dont think its OS related problem here.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #8 (permalink)  
Old 10th February 2010
Junior Member
BS.player Regular User
 
Join Date: Jan 2008
Posts: 13
Rep Power: 0
garren is an unknown quantity at this point
Default

Exactly just like mikeggsm said, these column on the right only appear if i use EVR rendering and it still happen if i use Windows XP (yeah, i used to be XP user before and been using BS.Player since then) or Windows 7 (which is my new OS now) so it does not matter which OS is in my case. Yeah, same thing here about if i change it to BMP format to capture, the column on the right will disappear but, the size of BMP are killing me (3MB per pics) x_x

and i still cant solve anything about the image being captured with only by press 'P' while in fullscreen mode will result in bigger size (1680 x 945) but not in the original image size (1280 x 720). But if i test it with internal renderer overlay (default), the picture will always be in their original size whether you're capturing image while in fullscreen mode or not.

of course i would refer EVR for my rendering since im using Windows 7 now, for the complete compatible for video playback. i believe its a bug here. I would love to use internal renderer overlay (default) as my alternate rendering but, it will always turn off aero and change my windows theme to basic when playing any videos which is, quite annoying to wait for it to switch back and forth everytime i played videos. @_@

It would be much appreciated too if BS.Player Team could find out how to make aero won't clash with the default overlay renderer.

and again BSPeter, thanks for the response. :)
Reply With Quote
  #9 (permalink)  
Old 11th February 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

Quote:
Originally Posted by garren View Post
... It would be much appreciated too if BS.Player Team could find out how to make aero won't clash with the default overlay renderer. ...
Quote:
Originally Posted by Ico-man View Post
AERO and OVERLAY will NOT work at the same time, as they are technically incompatible.

So you have to decide if you want Aero, OR if you want to use overlay.

If you want Aero, then you should select EVR renderer, which will be default video renderer in the future.
Moving this thread to Bugs-forum concerning the screencapture problems, viz.
(1) a few pixels wide left-hand column appearing at the right-hand side of the screen (only for screencaps in .jpg)
and
(2) different sizes of the captured images depending on screencaps being done in window or full screen playback (in EVR).
I'm unable to confirm either of the two. Sofar both users with this phenomenon use ATI-cards. Other users please?.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #10 (permalink)  
Old 11th February 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

Quote:
Originally Posted by garren View Post
... these column on the right only appear if i use EVR rendering and it still happen if i use Windows XP (yeah, i used to be XP user before and been using BS.Player since then) or Windows 7 (which is my new OS now) so it does not matter which OS is in my case.
This column appears under Win7 using EVRenderer and under WinXP it also appears when you use ... (rendering mode)?
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #11 (permalink)  
Old 11th February 2010
Junior Member
BS.player Regular User
 
Join Date: Jan 2008
Posts: 13
Rep Power: 0
garren is an unknown quantity at this point
Default

oh thanks a lot for moving this thread to its right section BSPeter! The column on the right also appeared in my Windows XP when i force my XP to use EVR rendering in BS.Player. although i know EVR are not meant for XP but only for Vista and Windows 7, i found out that the video playback are much smoother than overlay default, and also when capturing image with EVR, the color looked good, except the line column on the right.

Not only that, the size also became bigger just like i told you before, when capturing image in fullscreen, it'll became 1680 x 945 too. Im using the same Radeon X1650 AGP back when im still an XP user back then. I only upgraded my OS to Windows 7 without upgrading my hardware.

I wonder if these line column only affect us Radeon user but not to Nvidia user when using EVR as video rendering in BS.Player?
Reply With Quote
  #12 (permalink)  
Old 12th February 2010
Junior Member
BS.Player Newbie
 
Join Date: Feb 2010
Posts: 6
Rep Power: 0
mikeggsm is on a distinguished road
Default

I don't think it's a bug in the Radeon drivers because the right column garbage problem doesn't happen in Zoom Player and neither in Media Player Classic.

I just retried, and as stated the bug happens only with EVR, not VMR9, and only in JPG, not BMP.

mikeggsm
Reply With Quote
  #13 (permalink)  
Old 13th February 2010
Junior Member
BS.player Regular User
 
Join Date: Jan 2008
Posts: 13
Rep Power: 0
garren is an unknown quantity at this point
Default

That, is what i had in mind too mikeggsm, seems to me its more like a bug in BS.Player itself when capturing image while using EVR rendering mode. unfortunately, i dont have any nvidia user in my house here to test it out. i dont know about BSPeter's though, maybe he got no line column at all while using EVR? since i forced my XP to use EVR rendering, why dont you give it a try too BSPeter? the line column is still there when i use XP with EVR.

If BSPeter's got no line column, maybe the probability is quite high on graphic driver related problem.

Thank you.
Reply With Quote
  #14 (permalink)  
Old 13th February 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

Tested further and bugs confirmed for screencaps ('orig. size') in .jpg and using EVR:
(1) a few pixels wide left-hand column appearing at the right-hand side of the screen
and
(2) different sizes/resolutions of the captured images depending on screencaps being done in windowed or full screen mode.
(e.g.:
BS.Player's Media info on the 16:9 movie I used: video size 704x576, Aspect 11264:6336 (1024x576)
BS.Player's jpg screencaps windowed/full screen: 1147x645 pixels resp. 1258x708 pixels
User garren's examples (3rd post) for a 1280x720 movie: 1280x720 resp. 1680x945)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #15 (permalink)  
Old 13th February 2010
Junior Member
BS.player Regular User
 
Join Date: Jan 2008
Posts: 13
Rep Power: 0
garren is an unknown quantity at this point
Default

Thank you very much to BSPeter for joining mikeggsm's thread here and helped to confirm the bug. you've been a great help here in this thread! thanks again!

It's up to BS.Player team now to fix the bug and good luck to you all. we'll be counting on you.

BS.Player rockz! :)
Reply With Quote
  #16 (permalink)  
Old 7th March 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

Bug still present in 1024beta.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #17 (permalink)  
Old 8th March 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

Bug partly fixed in 1025beta (tested in Free version; couldn't test in Pro; it crashes!)
Left-hand column appearing at the right-hand side of the screen now gone.

However 2nd issue: different sizes/resolutions (depending on full or windowed screen) still there.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #18 (permalink)  
Old 22nd March 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

UNCHANGED in 1028/1029/1030-builds (2nd issue still there).
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #19 (permalink)  
Old 29th March 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

Ditto for 1031-build
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #20 (permalink)  
Old 11th April 2010
Junior Member
BS.player Regular User
 
Join Date: Jan 2008
Posts: 13
Rep Power: 0
garren is an unknown quantity at this point
Default

It's better than nothing i guess! :) at least i won't be seeing that vertical line at the right side of my snapshot anymore, thank you to BSPlayer Team and also thanks a lot for BSPeter too! :D

I'm still hoping for the better of it. yeah i really hope the 2nd issue will be fixed soon! and the bs player will be perfect to frame capture any snapshot with EVR rendering mode. :D :D

Thanks again!
Reply With Quote
Reply

Tags
capture, screen

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
Full screen problems tpedro Bug Reports And Codecs 2 5th March 2009 01:26 PM
Multiple screen problems Aiken Bug Reports And Codecs 0 15th November 2007 03:13 PM
Screen capture in Original Size only Rhoddlet Bug Reports And Codecs 16 8th January 2007 10:55 AM
problems with tv screen after using bsplayer saniel Bug Reports And Codecs 0 25th January 2005 01:17 PM
Cant capture screen as fullsize. Donald General Talk And Support 0 19th February 2004 11:26 PM


All times are GMT +1. The time now is 03:57 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20