Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 3rd November 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2011
Posts: 22
Rep Power: 0
PetrBlade is on a distinguished road
Default [FIXED but other bug reported] Some chars from previous sub stuck in the black border

You can see my problem clearly in the photo.
This video is 4:3, so there is added the black border, but some longer subtitles stuck there and next one goes over them... so there are few letters stucked in the border and I can put them away only with on/off fullscreen mode.

I'm using: .avi, .srt, WinXP, BSPlayer 2.58.1058

Thanks for advices.
Attached Images
File Type: jpg screen.jpg (90.0 KB, 5 views)

Last edited by PetrBlade; 29th December 2011 at 06:32 PM.
Reply With Quote
  #2 (permalink)  
Old 4th November 2011
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 26
BSPeter is on a distinguished road
Default

Using old/ or "new subtitle parser/renderer"?
(under rightclick > Options > Preferences > Subtitles)
If not using new subtitle engine, try whether problem is solved if you check that option!
If not solved:
(Also there: is "Draw subtitles to Overlay surface" selected?)
What is "Rendering mode" used?
(under rightclick > Options > Preferences > Video > [Video rendering])
(Did you already try a different mode?)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #3 (permalink)  
Old 4th November 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2011
Posts: 22
Rep Power: 0
PetrBlade is on a distinguished road
Default

1) I don't use that, but I tried to check it, but still the same problem
2) I tried few of them right now, but non of them solved my problem

I think I has to do something with setting in Subtitles

Example: imagine 2 longer subtitles in video in time 35sec-40sec ("no1") & 45sec-50sec ("no2")
"play": so before no1 there are no subtitles - OK -> subtitle no1 popout - OK -> there starts problem: 5second with no subtitles, but I can see few letters in the black border -> subtitle no2 popout, but you can still see these letters in black border -> after no2 disappear, there are these letter from no1 and over it other letters from no2 ... and this could go over and over until I on/off fullscreen.

I hope you understand.
Thanks for reply.

Last edited by PetrBlade; 5th November 2011 at 09:43 AM.
Reply With Quote
  #4 (permalink)  
Old 4th November 2011
Ico-man's Avatar
BS.Support
BS.Player Power User
 
Join Date: Sep 2006
Location: Slovenia
Posts: 1,459
Rep Power: 10
Ico-man is on a distinguished road
Default

We will check it.
Reply With Quote
  #5 (permalink)  
Old 7th November 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2011
Posts: 22
Rep Power: 0
PetrBlade is on a distinguished road
Default

Thanks, this is only think I don't like about BS.Player, if you fix it (or tell me how to set it) I think other media players have no chance in my list of preferred MP's.
And please let me know if you fix it or you will know the solution.
Reply With Quote
  #6 (permalink)  
Old 27th November 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2011
Posts: 22
Rep Power: 0
PetrBlade is on a distinguished road
Default

Any fixes??

EDIT: I tried beta version and it seems to be fixed.
Thanks for that, finally it works proper

EDIT2: Works 100% fine, but you have to check "new subtitle parser/renderer" to make change

Last edited by PetrBlade; 28th November 2011 at 12:49 AM.
Reply With Quote
  #7 (permalink)  
Old 30th November 2011
Ico-man's Avatar
BS.Support
BS.Player Power User
 
Join Date: Sep 2006
Location: Slovenia
Posts: 1,459
Rep Power: 10
Ico-man is on a distinguished road
Default

Great!
Reply With Quote
  #8 (permalink)  
Old 3rd December 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2011
Posts: 22
Rep Power: 0
PetrBlade is on a distinguished road
Default

...But this bug was replaced by another

In attachment you can see what happen if are "high" letters in the subtitles (Š,Ř etc. - East Europe-Czech). Part of the letter (diacritic) is copied under the letter, now matter where the subtitles are located (black border/in movie).

I use BS.Player FREE 2.59.1060 BETA and my setting is:



Any solution?
Thanks.

EDIT: It happens only if "Use new subtitle parser/renderer" is checked, which fixes the original problem of this topic.
Attached Images
File Type: jpg DSC00370.jpg (109.5 KB, 4 views)
Reply With Quote
  #9 (permalink)  
Old 5th December 2011
Ico-man's Avatar
BS.Support
BS.Player Power User
 
Join Date: Sep 2006
Location: Slovenia
Posts: 1,459
Rep Power: 10
Ico-man is on a distinguished road
Default

Which font/font size and encoding? Can you send us this subtitle?
Reply With Quote
  #10 (permalink)  
Old 5th December 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2011
Posts: 22
Rep Power: 0
PetrBlade is on a distinguished road
Default

Subtitle:
"11
00:01:15,578 --> 00:01:17,145
Říkala, že jste byl velmi dobrý."

(file: American.Horror.Story.S01E09.Spooky.Little.Girl.HD TV.XviD-P0W4.srt)

Font size: If I change font size, it's still there.
Examples:
43:bigger part of diacritic is copied,
44-45:smaller part of diacritic is copied,
46-53:bigger,
54-55:again smaller.
So when it's number "x4" or "x5" it is less visible... wierd.

Font: Arial (script: 1st=Central European)

Encoding: XviD (rendering: Internal renderer overlay) - is it what you want?

Last edited by PetrBlade; 5th December 2011 at 03:56 PM.
Reply With Quote
  #11 (permalink)  
Old 6th December 2011
Ico-man's Avatar
BS.Support
BS.Player Power User
 
Join Date: Sep 2006
Location: Slovenia
Posts: 1,459
Rep Power: 10
Ico-man is on a distinguished road
Smile

Will be fixed in next beta.
Reply With Quote
  #12 (permalink)  
Old 6th December 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2011
Posts: 22
Rep Power: 0
PetrBlade is on a distinguished road
Default

OK, I'm looking forward for that. Until new beta I will use 45 font size, so it's less visible

I also tried different fonts. In some of them it's bugged and in some fonts there is no problem with showing. But Arial is the best font for subtitles, so I don't want to change it.
Reply With Quote
  #13 (permalink)  
Old 13th December 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2011
Posts: 22
Rep Power: 0
PetrBlade is on a distinguished road
Default

1063b installed and it's gone, thanks for bug fix.
Reply With Quote
  #14 (permalink)  
Old 29th December 2011
Junior Member
BS.player Regular User
 
Join Date: Nov 2011
Posts: 22
Rep Power: 0
PetrBlade is on a distinguished road
Default

Hi,
I found other problem in new subtitle parser/renderer. It's even in new version 2.61.1065.

Bug appears in fullscreen mode, when are in subtitles different formats, like italic or bold ("[/b]"/"[/i]"):
http://img220.imageshack.us/img220/6575/dsc00378qt.jpg
As you can see, part from last letter is cut a shows up in the beginning of the same line.

I hope this is the last one

And happy new year to bs.player team
Reply With Quote
  #15 (permalink)  
Old 7th January 2012
Junior Member
BS.player Regular User
 
Join Date: Nov 2011
Posts: 22
Rep Power: 0
PetrBlade is on a distinguished road
Default

UP...





Reply With Quote
Reply

Tags
black, border, letters, previous, stuck, subtitle, subtitles

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
my subtitle is black bsnick Subtitles 0 9th January 2010 08:04 PM
How can I put the subtitle on the black down ? cool_vartan Answered And Solved Questions 4 16th January 2009 10:00 AM
black border playerbs General Talk And Support 14 19th June 2008 07:22 PM
Black Border in Window Mode Jan General Talk And Support 2 3rd December 2003 07:31 PM
Black border on the right in desktop mode Loul Bug Reports And Codecs 0 11th November 2003 10:09 AM


All times are GMT +1. The time now is 10:10 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19