Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #21 (permalink)  
Old 26th November 2003
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 23
Tizio will become famous soon enough
Default

Try the flip option in ffdshow filters.
If you have them installed, right-click on BSPlayer and in the menu go to
"options - filters - advanced" then under ffdshow search for something like "flip image".
Let me know if it fixes the problem...
Reply With Quote
  #22 (permalink)  
Old 26th November 2003
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 23
Tizio will become famous soon enough
Default

I post following images for better understand what I mean in previous bugs posting:
- Horizontal/Vertical volume button (in some skins) has visualization problems near the rightest/highest position.
- [WID13]: Item 4 should be left-aligned
- In the properties window, video section, DivX4+ settings, a "rectangle" around 'Film Effect' is visible.
Attached Images
File Type: jpg Volume.jpg (3.6 KB, 829 views)
File Type: jpg Luminance_offset.jpg (3.8 KB, 837 views)
File Type: jpg Film_effect.jpg (1.5 KB, 836 views)
Reply With Quote
  #23 (permalink)  
Old 26th November 2003
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 23
Tizio will become famous soon enough
Default

If section [Display] is missing in SkinFS.ini, made the Full screen skin to appear nullify the Skin.ini "MaxTitleWidth" effect.

Quote:
Originally Posted by Tizio
- Horizontal/Vertical volume button (in some skins) has visualization problems near the rightest/highest position.
I think I've discovered the cause of the Horizontal (maybe also Vertical) Volume Button problem. Mentioned problem occours only when there are visible pixels which have CoordinateX=0 (It means it occours if the first left column is not filled only with the color of pixel(0,0)).

Bye!
Reply With Quote
  #24 (permalink)  
Old 27th November 2003
mia mia is offline
Junior Member
BS.player Regular User
 
Join Date: Nov 2003
Posts: 16
Rep Power: 0
mia is an unknown quantity at this point
Default

Quote:
Originally Posted by Tizio
Try the flip option in ffdshow filters.
If you have them installed, right-click on BSPlayer and in the menu go to
"options - filters - advanced" then under ffdshow search for something like "flip image".
Let me know if it fixes the problem...
Oops... not fixed, in ffdshow if i use flip option, then i must flip monitor :-))) AVI files seems OK (playing through ffdshow) but MPEG files are flipped (not playing through ffdshow). If i use ffdshow (libavcodec or libmpeg2) for MPEG files, then video seems very poor and/or bsplayer hung.
Reply With Quote
  #25 (permalink)  
Old 27th November 2003
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 23
Tizio will become famous soon enough
Default

Sorry for that suggestion, I'm not very skilled with MPEG files.. :oops:

Quote:
Originally Posted by mia
If i use ffdshow (libavcodec or libmpeg2) for MPEG files, then video seems very poor and/or bsplayer hung.
Does it means the image is shown correctly if you use that option?
I think it's better to view a poor image then a flipped one. :( However I know that viewing a poor image is an orrible alternative...
Try to ask that question to adicoto, maybe he could help you. :?:

I wish you to find a solution to this problem!!
Reply With Quote
  #26 (permalink)  
Old 28th November 2003
mia mia is offline
Junior Member
BS.player Regular User
 
Join Date: Nov 2003
Posts: 16
Rep Power: 0
mia is an unknown quantity at this point
Default

Quote:
Originally Posted by Tizio
Does it means the image is shown correctly if you use that option?
I think it's better to view a poor image then a flipped one.
Not exactly... video shown correctly (not flipped) but after playing some fields then freezes. Audio continued. If i use libmpeg2 instead libavcodec then bsplayer hung with error in module libmpeg2... grrrr :-(
Reply With Quote
  #27 (permalink)  
Old 28th November 2003
Junior Member
BS.Player Newbie
 
Join Date: Nov 2003
Location: Sweden
Posts: 5
Rep Power: 0
JemyM is an unknown quantity at this point
Default

BSPlayer confuses "Mouse Left-Doubleclick" with "Mouse Left+Wheel Down". This means that when trying to go into full screen by doubleclicking the window, the volume is lowered instead.

This is also true when trying to reassign "Full Screen Switch" option.

This was tested with an Intellimouse Explorer mouse.


Also, you cannot unselect registered filetypes, they are reset as soon as you close the preferences window. (BSPlayer keeps stealing mp3!!! :P)
Reply With Quote
  #28 (permalink)  
Old 28th November 2003
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 23
Tizio will become famous soon enough
Default

@mia
(in other thread adicoto wrote) Try installing a newer MPEG codec
http://forum.bsplayer.org/viewtopic.php?t=3042
Hope this could help
Reply With Quote
  #29 (permalink)  
Old 29th November 2003
Junior Member
BS.Player Newbie
 
Join Date: Nov 2003
Posts: 2
Rep Power: 0
yala is an unknown quantity at this point
Default problems with avi files

BSPlayer v1.00.803, Unhandled exception at EIP: 73F12594
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Invalid floating point operation
EInvalidOp
, 0x004E746F, 0x004E766D, 0x00453527, 0x0044A872, 0x77D37B17, 0x77D3CDCE, 0x77D14435, 0x77D14D38, 0x004E8584, 0x77E5EB69

___________

this is the message i got when opening a file i had already seen without any problems before installing bsplayer latest version.
WIth new version i had a lot of troubles with upside down images and had to install/unistall/reconfig all codecs.

Apparently I solved the upside down thing but i still have this problem with .avi files (i had the same with others but now they are ok).
What can i do?
Reply With Quote
  #30 (permalink)  
Old 29th November 2003
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 23
Tizio will become famous soon enough
Default

Another string missing in .lng file is the one for "Audio channels" which is present in Preferences' window under "Audio - InterVideo AC3".
Reply With Quote
  #31 (permalink)  
Old 5th December 2003
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 23
Tizio will become famous soon enough
Default

Hi! Finally I had some time to check the old skins' conversion process.
I'm very glad to see that for loading old skins (not compressed) BSPlayer creates a "skinv1.ini" file, and for compressed one there are no changes!! GREAT JOB! That way you can use those skins with both previous and next player's versions!
Anyway, there are some bugs in the conversion process:
- Jump backward command 39 is not converted as command 80 but as "BtnStop"
- Jump foreward command 38 is not converted as command 79 but as "BtnPause"
- Color control command 51 is not converted as command 98 but as ... something wrong
- Increase Font Size command 46 is not converted as command 83 but as ... something wrong
- Decrease Font Size command 47 is not converted as command 84 but as ... something wrong

- In a skin of mine buttons can't work due to a bad conversion: is not assigned a type (in my case 0) to the buttons, when in the original Skin.ini file there's the string "ButtonAnyShape=0".
Example: BtnPlay=36,86;Play [converted in] Btn2=bplay,36,86,,20;Play

Anyway I still say you've done a great work, and I hope you can fix these problems in your next BSP build!
Here's a quesion: why does the player creates a "skin.inifs.new" file (when converting old non compressed skins) that plus contains only the section [Display]?

I wish you a good work! Bye!
Reply With Quote
  #32 (permalink)  
Old 6th December 2003
Member
BS.player Regular User
 
Join Date: Feb 2003
Posts: 65
Rep Power: 0
tupac7 is an unknown quantity at this point
Default

SHITTY BUG:

link: http://forum.bsplayer.org/viewtopic.php?p=10062#10062

try it out! I have the same fuckin shit.. I dont use BSPlayer nomore because of this shit. (I have WinXP)
Reply With Quote
  #33 (permalink)  
Old 6th December 2003
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 23
Tizio will become famous soon enough
Default

There are other two bugs:
- Well, this is not really a bug, but some plugins remain on top of the video window, even if they haven't Always On Top feature!
- If you press "SHIFT+O" for the Custom Pan&Scan option when in full screen the mouse is NOT shown, the Pan&Scan window appears, but the mouse still remains hidden!!

@tupac7
Yes, there's a problem with stealing of file associations. I had that problem too, but now I've solved it. Don't know how, but let me try again and I'll post how to do.

There are still many bugs, but I don't think BSP is so buggy to don't use it nomore...
Just be patient and wait, I'm sure BST and mat2000 will fix all the problems! :)
Reply With Quote
  #34 (permalink)  
Old 19th December 2003
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 23
Tizio will become famous soon enough
Default

HI! When going in full screen mode with auto hide main window option enabled, the mouse cursor doesn't disappears, you have to move it after the main window hides, and then it disappears...

There's another "bug". Well, it isn't really a bug, but it is a little annoying: I know that the character '&' is used to underline the character used with keyboard's shortcuts, but where's the utility with File names??
Example: If a movie is named for example "Lilo & Stitch", the title shown will be "Lilo _ Stitch".
Renaming the file in "Lilo && Stitch" fix the problem, but is not... a good choise if using other players I will see "Lilo && Stitch" as title.

I know it's a "stupid" problem, and it's NOT so urgent, but I wanted to notice it anyhow.
I hope to hear from you as soon as you can! Bye :)
Reply With Quote
  #35 (permalink)  
Old 21st December 2003
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 23
Tizio will become famous soon enough
Default

@BST
There's any way to fix the forum problem "Could not find email template file topic_notify"? Maybe with a new one version?

Thanks in advance
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 09:19 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20