Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 3rd July 2005
Junior Member
BS.player Regular User
 
Join Date: Jan 2004
Posts: 18
Rep Power: 0
damienffm is an unknown quantity at this point
Default Prblems with Matroska Files with different audio channels

Hello,

unfortunately BSPlayer pro 1.32 820 don´t show more than one audio channel in matroska files.

I have matroska files with one video channel, two audio channels and subtitels and chapterinfo. So far Subtitles and chapters are working well only it is not possible to switch between the two audio channels. So one channel is ac3 sound and the other aac 5.1 sound.

Is it possible to tell BSPlayer wich audio track it should use?

Thx

alexander
Reply With Quote
  #2 (permalink)  
Old 28th July 2005
Member
BS.player Regular User
 
Join Date: Jun 2003
Location: Groningen, The Netherlands
Posts: 68
Rep Power: 0
ZanderZ is an unknown quantity at this point
Default

I've got a similar problem, I have a movie with English and French audio and French is standard. Ofcourse that sucks and I want to watch with English audio but I can't change it.
It worked fine in earlier builds...

-edit- to make it even weirder, BSPlayer's audio settings have English (eng) as default language.
__________________
Creator of BadFellas, a free online mafia game: http://www.badfellas.org
Reply With Quote
  #3 (permalink)  
Old 7th August 2005
Member
BS.player Regular User
 
Join Date: Jun 2003
Location: Groningen, The Netherlands
Posts: 68
Rep Power: 0
ZanderZ is an unknown quantity at this point
Default

I'm kicking this thread because it's very annoying and it's a pretty big bug.
At the "key definitions" page, it has two options: "scroll through audio channels" and "scroll to soundchannels" (I'm using Dutch so the text might be a bit different in English)
When I use the first, nothing happens. The second one says "Channel 1", then "Channel --" when I use it. The sound doesn't change.
It works fine in MPC so the second channel does exist.

BSPlayers audio settings are set to 1 (default audio channel) and "eng" (default audio channel (language code))
Changing the first to 2 or 0, or the second to "en" doesn't help.
__________________
Creator of BadFellas, a free online mafia game: http://www.badfellas.org
Reply With Quote
  #4 (permalink)  
Old 8th August 2005
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

Hello ZanderZ
The second option concerns "Audio stream volume cycle" (default Ctlr+S), but it doesn't seem to do very much, except for the "OSD-reports"as mentioned by you. Couldn't test the first option "Cycle audio streams" (default Shift+S) with a matroska file, but it does e.g. work for me in the "Revelations.divx" (DivX6 encoded) demo movie. [Mind you, as a WinMe user, I use DivX5.2.1-codec as decoder.]

Perhaps you also stepped on an imperfection in the Dutch translation ("volume"), which probably has been there for quite some time already (I didn't check it out yet). I will rectify that in due time! Thanks for your remark on this!
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #5 (permalink)  
Old 9th August 2005
Member
BS.player Regular User
 
Join Date: Jun 2003
Location: Groningen, The Netherlands
Posts: 68
Rep Power: 0
ZanderZ is an unknown quantity at this point
Default

I tried the Revelations movie, and in that case it did work. I'll see if I can find an older build...
Translating can become a pain in the ass after a while, making a small mistake can occur ;)

-edit-
Tried build 817, doesn't work there either. Maybe BSPlayer depends on some filter (stream switcher?) and MPC does not? I'll do some more testing tomorrow
__________________
Creator of BadFellas, a free online mafia game: http://www.badfellas.org
Reply With Quote
  #6 (permalink)  
Old 22nd August 2005
Member
BS.player Regular User
 
Join Date: Jun 2003
Location: Groningen, The Netherlands
Posts: 68
Rep Power: 0
ZanderZ is an unknown quantity at this point
Default

Did some more testing, but can't find out how to fix it.
When loading a MKV file, at Options-Filters it has Morgan Stream Switcher. This only shows one audio track (French).
I installed Haali Media Splitter, didn't help, it doesn't show under Filters or anything.
Both Haali Media Splitter as BSPlayer itself have "audio language priority"/"standard audio channel" set to "eng"

As said before, it works fine in MPC.
__________________
Creator of BadFellas, a free online mafia game: http://www.badfellas.org
Reply With Quote
  #7 (permalink)  
Old 24th August 2005
Member
BS.player Regular User
 
Join Date: Jun 2003
Location: Groningen, The Netherlands
Posts: 68
Rep Power: 0
ZanderZ is an unknown quantity at this point
Default

Just tried build 823, it works now ^^
It does display an error when I open an MKV, but pressing Continue works.
__________________
Creator of BadFellas, a free online mafia game: http://www.badfellas.org
Reply With Quote
  #8 (permalink)  
Old 24th August 2005
bst's Avatar
bst bst is offline
BS.Developer
BS.Player Power User
 
Join Date: Jun 2002
Posts: 181
Rep Power: 10
bst will become famous soon enoughbst will become famous soon enough
Default

It should be fixed in night build (here or here)
Reply With Quote
  #9 (permalink)  
Old 24th August 2005
Member
BS.player Regular User
 
Join Date: Jun 2003
Location: Groningen, The Netherlands
Posts: 68
Rep Power: 0
ZanderZ is an unknown quantity at this point
Default

Yes it is, great work :)
There's still one problem though :( external subtitles don't work when I load an MKV file (with subtitles included), the internal subtitles do work.
External subtitles also work normally for AVI's (DivX/Xvid) and MPEG's.
I can't test MKV's without internal subtitles, so I don't know if it works in that case.
__________________
Creator of BadFellas, a free online mafia game: http://www.badfellas.org
Reply With Quote
  #10 (permalink)  
Old 24th August 2005
bst's Avatar
bst bst is offline
BS.Developer
BS.Player Power User
 
Join Date: Jun 2002
Posts: 181
Rep Power: 10
bst will become famous soon enoughbst will become famous soon enough
Default

Yes, there is problem with external subtiles if internal are present, will be fixed in next build.
Reply With Quote
  #11 (permalink)  
Old 29th August 2005
Member
BS.player Regular User
 
Join Date: Jun 2003
Location: Groningen, The Netherlands
Posts: 68
Rep Power: 0
ZanderZ is an unknown quantity at this point
Default

Thanks for the reply :) I hope it will be done soon.
One other thing that might be related (but it might not be):
I've got a movie (AVI DivX) which plays fine, subtitles work, all is fine. Let's say the name of this movie is "Moviename [FTV].avi"
When I have an SRT file "Moviename [FTV].srt" suddenly I can't play the movie anymore. When I rename the SRT file to something else, it works fine again.
This happens to some movies with the same SRT filename, but not to all. Very weird, but just of minor inconvenience.
__________________
Creator of BadFellas, a free online mafia game: http://www.badfellas.org
Reply With Quote
  #12 (permalink)  
Old 5th September 2005
Member
BS.player Regular User
 
Join Date: Jun 2003
Location: Groningen, The Netherlands
Posts: 68
Rep Power: 0
ZanderZ is an unknown quantity at this point
Default

Working great again :) Thanks a lot!
__________________
Creator of BadFellas, a free online mafia game: http://www.badfellas.org
Reply With Quote
Reply

Tags
audio, channels, matroska, prblems

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 03:51 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20