Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 3rd January 2012
Junior Member
BS.player Regular User
 
Join Date: Jan 2012
Age: 81
Posts: 15
Rep Power: 0
ssdevious is on a distinguished road
Default Loading Subtitles & Maximizing Causes Terrible Screen Lags

Hello,

I'm very sorry for bothering your support, but I'm in a need of urgent help.

After BS Player kept reminding me for more then a half a year that I should upgrade to a newer version, I couldn't resist anymore and I did it. The result is why I'm typing this message.

I start playing an .mkv, everything is fine as long as it's small window, 400 x 200 px, but then I load subtitles, maximize it and after 3 or 4 seconds, the screen gets some seizure, while being caught in a loop or it isn't actually a loop, it is moving forward, but like 2 or 3 frames forward, then it goes 2 frames backwards, it's really crazy, the sound does the same, only subtitles are more or less working.

Please, I will be grateful for any help provided.

Thank you.

Best Regards,
~tEh'Pâr4d0x
Reply With Quote
  #2 (permalink)  
Old 4th January 2012
Junior Member
BS.player Regular User
 
Join Date: Jan 2012
Age: 81
Posts: 15
Rep Power: 0
ssdevious is on a distinguished road
Default

Apologies for a double post, but...

I found out, it might be related to video rendering option called "EVR", when I disable it, it no longer lags, however:

A) video is simply a crap, it's 720p rip, after switching from "EVR" to different render, it's like 640x320 crappy DVDrip

B) subtitles have this awful black contour around it, it just looks terrible

So, is there a better solution to this than uninstalling BS Player? I kind of like your software, it's really good one, but how come that some 1 year old version works better than the current one? I mean, I was using 2.57 I think, it was working just nicely on Windows 7, so how come, a newer version suffers from such handicap and literally kills the experience for all Aero users and let's be honest, 99,9% Vista and Windows 7 users started using it just because of those fancy new graphics.

1) Is there a solution, some codec pack or anything?

2) Is PRO version having same issues?

3) Can this be dealt with otherwise?

Please, let me know. I don't mind buying the PRO one or sponsoring your site or anything, I just want to cross this problem out of my to-do list and move on.

Best Regards,
tEh'Pâr4d0x
Reply With Quote
  #3 (permalink)  
Old 4th January 2012
Junior Member
BS.player Regular User
 
Join Date: Jan 2012
Age: 81
Posts: 15
Rep Power: 0
ssdevious is on a distinguished road
Default

Please, any suggestions?

Thanks.

Best Regards,
~tEh'Pâr4d0x
Reply With Quote
  #4 (permalink)  
Old 4th January 2012
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

I suppose you're presently using version/build nr 2.6.1.1065.
Also suppose you're using either Vista or Win7.
It appears you switched from EVR-renderer to ... another renderer (but fail to mention which one)?
Probably (also in view of your remark re Aero) you switched to "internal renderer (overlay)" or ...?
In this connection please read this post by Ico-man.
You mention that subtitles "have this awful black contour around it".
Do you mean a black background? Or are the subs in an outline font? You can set/select this under
rightclick > Options > Preferences > Subtitles [Subtitle properties].
In that same window:
is "Use anti-aliased font" selected?
is "Use new subtitle parser/renderer" selected?

P.S.:
A codec-pack surely is NOT a good idea!
I suppose you allowed BS.Player (when you installed it) to also internally install its preferred codecs/filters? (Note internally meaning: for use by BS.Player only and not interfering with your systems codecs/filters)?
Maybe let us know which filters/codecs BS.Player is actually using when playing a problematic video file.
To see these filters/codecs: rightclick>Options>Filters>Advanced.
Then click on "Source" and on the small [+]-signs in front of the filters/codecs shown to reveal further info and access.
(Are you sure you're born on 01 Jan 1938?)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #5 (permalink)  
Old 4th January 2012
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

Something like:

Official BS.Player forums

Issues I have with BS.Player

Is it VMR9 renderless ?
Reply With Quote
  #6 (permalink)  
Old 4th January 2012
Junior Member
BS.player Regular User
 
Join Date: Jan 2012
Age: 81
Posts: 15
Rep Power: 0
ssdevious is on a distinguished road
Default

Thank you Peter!

1) Yes, I'm using the current version. Interesting / weird thing is that my old version (2.57 I believe, plus it was some BETA..) never had such issues. But yes, atm. I'm using 2.61 1065.

2) Windows 7 Home Premium 64bit.

3) EVR: I found somewhere that the EVR might be causing this, so I switched, one by one, to all other available alternatives and one was worse than another. One killed my Aero, another most likely kept Aero on, but the video (720p rip) looked really rubbish, plus the subtitles looked awful, in EVR the subs had just a tiny black contour around it, very thin and very sharp, but with any other renderer it looked really terrible, certainly no-go way.

I will try the "New Subtitles Parser", the other one ("Anti-Aliased") was already on. And read that other post.

Certainly this is no FREE version limitation? It's all .mkv doing the same, I haven't tested on .avi or others, because I frankly have no idea, where to get an .avi video atm., all movies are in .mkv these days, 720p and 1080p rips, unless it's full untouched BluRay.

Thank you a lot for your assistance, I really appreciate it.

Best Regards,
~tEh'Pâr4d0x
Reply With Quote
  #7 (permalink)  
Old 4th January 2012
Junior Member
BS.player Regular User
 
Join Date: Jan 2012
Age: 81
Posts: 15
Rep Power: 0
ssdevious is on a distinguished road
Default

Quote:
Originally Posted by adicoto View Post
Something like:

Official BS.Player forums

Issues I have with BS.Player

Is it VMR9 renderless ?
Not precisely. The quality more or less remains unchanged, but it's something like 1 FPS, plus terribly fitful video, after 5 or 6 seconds, it's about to cause you a terrible eyesore.

Best Regards,
~tEh'Pâr4d0x
Reply With Quote
  #8 (permalink)  
Old 4th January 2012
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

Just tested an MKV file. Strange thing.I personally prefer internal renderer because, IMHO, on my computers works the best. So, I've swiched to EVR to see and stumbled uppon 2 interesting things.
1. having external RAR/IDX files, BSPlayer play the file with stuttering. (same file, previous build worked OK)
2. Using an external .srt file, it works OK
3. I don't have ATM an MKV with internal subtitles to test how it works.

4. Frame rate reported when playing the file....59,94 fps. File is certainly 29,97
5. After swiching back to internal renderer....29,97 fps.

Something is wrong here.

Using Gabest MKV, CoreAVC, AC3filter
Reply With Quote
  #9 (permalink)  
Old 4th January 2012
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

Quote:
Originally Posted by ssdevious View Post
Not precisely. The quality more or less remains unchanged, but it's something like 1 FPS, plus terribly fitful video, after 5 or 6 seconds, it's about to cause you a terrible eyesore.

Best Regards,
~tEh'Pâr4d0x
I was refering strictly at the image with the black border.
Reply With Quote
  #10 (permalink)  
Old 4th January 2012
Junior Member
BS.player Regular User
 
Join Date: Jan 2012
Age: 81
Posts: 15
Rep Power: 0
ssdevious is on a distinguished road
Default

Internal renderers kills the Aero for me, it's mentioned in that topic Peter linked before. Some support guy explains in that topic that internal renderers are technically incompatible with Aero and that we should stick to EVR.

From what I've experienced, it's either EVR or nothing, because the other render settings looks even more weird to me and that Aero switch glitch, for someone who watches one movies a week, fine, but for someone, who watches a dozen videos daily, it's another eye killer, e.g. go basic display -> Aero -> basic -> Aero with each BS Player ON / OFF.

Probably, there might be a way, what Peter suggested, exploring what codecs or similar stuff are used during the play and analyze that.

FILTERS (playing .mkv):

Code:
AsyncClock
Default DirectSound Device
Video Renderer
Microsoft DTV-DVD Audio Decoder
Microsoft DTV-DVD Video Decoder
Source
-> This is what I see, when I open the "Options" - "Filters" - "Advanced".

Best Regards,
~tEh'Pâr4d0x
Reply With Quote
  #11 (permalink)  
Old 4th January 2012
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

A, ok. Look, Microsoft's codec is a total failure (Microsoft DTV-DVD ). Try to install ffdshow or CoreAVC. Problem should be fixed.

PS: I know that internal renderer kills Aero, but I'm OK with that. I personally don't need Aero while whatching a movie. And...there is an option to re-enable Aero only when closing BSPlayer, so if you play 2-3 files you get only 2 flickers, at begining of first video file and when closing BSPlayer.
Reply With Quote
  #12 (permalink)  
Old 4th January 2012
Junior Member
BS.player Regular User
 
Join Date: Jan 2012
Age: 81
Posts: 15
Rep Power: 0
ssdevious is on a distinguished road
Default

Yeah, that's all right. I mean, you don't need Aero, while in full-screen mode, but the swaps are hurting,...

Anyway, should I randomly Google those codecs or is there any specific recommended place to get them?

Thanks,
~tEh'Pâr4d0x
Reply With Quote
  #13 (permalink)  
Old 4th January 2012
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

You can install ffdshow using codecmanager.exe from BSPlayer's install folder or you can go here:

Free-Codecs.com : Download FFDShow MPEG-4 Video Decoder 2011-12-27, FFDShow MPEG-4 Video Decoder 2011-11-29 and FFDShow MPEG-4 Video Decoder 2011-12-27 x64 : FFDSHOW is a DirectShow decoding filter

you will also need an MKV splitter (that you probably have installed - Haali or Gabest)
Reply With Quote
  #14 (permalink)  
Old 4th January 2012
Junior Member
BS.player Regular User
 
Join Date: Jan 2012
Age: 81
Posts: 15
Rep Power: 0
ssdevious is on a distinguished road
Default

Quote:
Originally Posted by adicoto View Post
You can install ffdshow using codecmanager.exe from BSPlayer's install folder or you can go here:

Free-Codecs.com : Download FFDShow MPEG-4 Video Decoder 2011-12-27, FFDShow MPEG-4 Video Decoder 2011-11-29 and FFDShow MPEG-4 Video Decoder 2011-12-27 x64 : FFDSHOW is a DirectShow decoding filter

you will also need an MKV splitter (that you probably have installed - Haali or Gabest)
I will try this one, thanks. However, I think BS Player installs it during its own installation.

Regards,
~tEh'Pâr4d0x
Reply With Quote
  #15 (permalink)  
Old 4th January 2012
Junior Member
BS.player Regular User
 
Join Date: Jan 2012
Age: 81
Posts: 15
Rep Power: 0
ssdevious is on a distinguished road
Default

1 thing actually improved, I have my sound back, but the video is still choppy, when maximized and with external subtitles loaded in.

Funny thing, a friend of mine, who has also these problems, but unlike me, he keeps old releases of software sent me his 2.43 and it works just fine with EVR, etc.

What was so radical that changed between these versions? I mean, there's a lot of stuff which changes I guess, but I believe the last version working fine for me was 2.57, then just something went wrong.

Any guesses? Or should I try to browse for more codes, perhaps focus on those, which goes for .mkv, I also don't want to screw up my PC more then necessary.

Thanks,
~tEh'Pâr4d0x
Reply With Quote
  #16 (permalink)  
Old 4th January 2012
Junior Member
BS.player Regular User
 
Join Date: Jan 2012
Age: 81
Posts: 15
Rep Power: 0
ssdevious is on a distinguished road
Default

Apologies to bother again, I probably ought to go PRO and get the premium support anyway, I know this is for free and I very appreciate your attitude and interest trying to help me out.

:::THINGS WE KNOW SO FAR:::

I've reinstalled the BS Player, all codecs and stuff and after I made it even worse during this whole procedure, I'm back at square one, which is actually a good thing.

1) 2.61 1065 works FINE, when an .mkv is opened in small window.

2) 2.61 1065 works FINE, when an .mkv is opened and maximized.

3) When external (.srt / .sub) subtitles are loaded into the movie, it causes the choppy screen glitch. Every new scene or every 3 or 4 seconds, it somewhat pauses itself, plays the same frame over like 20 or 30 times, but very, very fast, like 2 or 3 secs., then it goes on for another 4 or 5 seconds normally, stops again, replays the current frame very, very fast around 20 or 30 times, then moves on again.

:::FEW QUESTIONS:::

1. It apparently installed all the necessary codecs, but when I check filters, it seems that it's not using them. How can I select, which codec it will use or is it even possible?

2. How can I check all my codecs on PC?

3. When I go to the preferences, there's "General", "Video" and "Audio" and others. In the "Video" tab, there is 2x "DivX" and "FFD" and all are non-clickable, I cannot click on those, is it good or bad?

4. PRO version has better codecs or the difference is just between those YouTube functions and some other stuff?

Thank you very much. BS Player is the best!

Best Regards,
~tEh'Pâr4d0x
Reply With Quote
  #17 (permalink)  
Old 5th January 2012
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

FEW ANSWERS:

1. and 2. In BSPlayer's options, there is "filter management". In there you can see ALL filters installed on your computer and also you can blacklist filter you don't want BSPlayer to use.

3. Those options are a legacy of old BSPlayers and the functions are available only when DivX3.11, DivX 4 or ffdshow are loaded by BSPlayer while playing a video file.

4. Yes, difference is only in DVD, YouTube and other stuff.

FEW QUESTIONS:

1. Which filters are used now to play the MKVs ?

2. Can you do one more test ? Uninstall all codecs installed by BSPlayer, except for Haali and AC3filter. Install CoreAVC and CoreAAC. Play an MKV and post here which filters are used to play the file.
Reply With Quote
  #18 (permalink)  
Old 5th January 2012
Junior Member
BS.player Regular User
 
Join Date: Jan 2012
Age: 81
Posts: 15
Rep Power: 0
ssdevious is on a distinguished road
Default

Will try later today, thanks so far. Appreciate your help!

Best Regards,
~tEh'Pâr4d0x
Reply With Quote
  #19 (permalink)  
Old 5th January 2012
Junior Member
BS.player Regular User
 
Join Date: Jan 2012
Age: 81
Posts: 15
Rep Power: 0
ssdevious is on a distinguished road
Default

1. Microsoft's DTV-DVD Audio and Video decoders.

2. How do I do that? I know, it's a dumb question, but codecs overall don't have an uninstall button, so shall I use some manager or search & manual Del.?

Best Regards,
~tEh'Pâr4d0x
Reply With Quote
  #20 (permalink)  
Old 5th January 2012
Junior Member
BS.player Regular User
 
Join Date: Jan 2012
Age: 81
Posts: 15
Rep Power: 0
ssdevious is on a distinguished road
Default

And 3rd in row.., sorry..

I googled AVC and it seems, it's paid one, is that correct? Any free alternative? Please link.

Concerning AAC, I found one on free-codecs.com, but it's from 2006, is it even safe to be getting that one?

Thanks,
~tEh'Pâr4d0x
Reply With Quote
Reply

Tags
loading, maximizing, screen, subtitles, terrible

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
subtitles black out screen onebigoaf Subtitles 8 14th January 2017 04:56 PM
Subtitles disappear with full screen noelcm Subtitles 0 13th May 2010 07:03 AM
Regarding the loading of subtitles REDONDOS General Talk And Support 1 12th July 2005 09:14 PM
Subtitles not load when loading movie second time trodas Bug Reports And Codecs 2 13th September 2003 01:07 AM
Subtitles BSPeter General Talk And Support 0 23rd November 2002 02:16 PM


All times are GMT +1. The time now is 06:04 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20