Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 6th May 2009
Junior Member
BS.Player Newbie
 
Join Date: May 2009
Posts: 6
Rep Power: 0
Desertfox92 is on a distinguished road
Default Got a problem with AC3 filter sound

I've just got a 5.1 surround set and they all 5 boxex sub are working, how ever I wanted something else then the Realted HD audio configuration tone when you test your speakers. I have this dolby digital sound test disc which hass all those intros from THX, DTS dolby etc... but I wasn't getting surround sound.(sound that should be behind me was in front of me) so I went to the AC3 filter config and saw that the input was 5.1, but the output was 2.0 so I changed it to 3/2 SW (3 front 2 back sub) (as the manuel also suggests) but now all the sounds are really low qualety and its really loud, especially voices main sounds. the output is now the same is the input (5.1) but I don't think its supposed to be like this.

Thanks.

edit: just read the sticky about things you should post so here we go:

BS player 2.40 april 2009 build

Windows vista 64bit
Dual core 2.8 ghz
ATI HD4850 512mb
4 gig dual channel 800mhz ram
Reply With Quote
  #2 (permalink)  
Old 7th May 2009
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Just to be sure which AC3Filter setting ("Main"-tag) you selected:
"3/2 - 5 channels" or "3/2+SW 5.1 channels"?
(Noticed there are also 2 Dolby Surround settings?)
And what is selected as PCM just below that?
And "Use SPDIF"?
Is AC3Filter shown (with an appropriate file loaded) under
(rightclick >) Options > Filters > Advanced ...? resp.
(rightclick >) Options > Preferences > Audio ...(south east corner)?

(Perhaps also check the other AC3Filter-settings under its Mixer/Gains/System-tags)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #3 (permalink)  
Old 7th May 2009
Junior Member
BS.Player Newbie
 
Join Date: May 2009
Posts: 6
Rep Power: 0
Desertfox92 is on a distinguished road
Default

Quote:
Originally Posted by BSPeter View Post
Just to be sure which AC3Filter setting ("Main"-tag) you selected:
"3/2 - 5 channels" or "3/2+SW 5.1 channels"?
(Noticed there are also 2 Dolby Surround settings?)
And what is selected as PCM just below that?
And "Use SPDIF"?
Is AC3Filter shown (with an appropriate file loaded) under
(rightclick >) Options > Filters > Advanced ...? resp.
(rightclick >) Options > Preferences > Audio ...(south east corner)?

(Perhaps also check the other AC3Filter-settings under its Mixer/Gains/System-tags)
Thank you for your response


Its set to 3/2+SW 5.1 channel
The dolby surround settings seem to do nothing (still FR and LR)
PCM is set as 16bit
SPDIF is disabled
Yes
Yes under Intervideo AC3 (this also has a 5.1 option but does not do anything.

btw I see that you are dutch. Ik ook!
Reply With Quote
  #4 (permalink)  
Old 7th May 2009
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 49
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Since Vista came out, 5.1 playback was problematic. So, if the sound is distorted, when playing such a file, open AC3Filter dialog window (rightclick -> options -> filters -> AC3Filter and go to GAINS TAB. In here you should see the input and output levels. If the output level it's at the roof, the this ia the cause for the distortions and you should reduce volume from the main slider (be sure AGC it's not enabled).
Reply With Quote
  #5 (permalink)  
Old 7th May 2009
Junior Member
BS.Player Newbie
 
Join Date: May 2009
Posts: 6
Rep Power: 0
Desertfox92 is on a distinguished road
Default

Quote:
Originally Posted by adicoto View Post
Since Vista came out, 5.1 playback was problematic. So, if the sound is distorted, when playing such a file, open AC3Filter dialog window (rightclick -> options -> filters -> AC3Filter and go to GAINS TAB. In here you should see the input and output levels. If the output level it's at the roof, the this ia the cause for the distortions and you should reduce volume from the main slider (be sure AGC it's not enabled).
The output levels are normal, the same as the input levels.
When i put the output to 3/2 (5 channels) instead of 3/2+sw (5.1) The dialouge seems more normal, but its still to loud and there's olmost no bass anymore

Edit: after some testing it seems that 3/2 works better then 3/2+sw is some videos. it also seems that the back speakers have the same audio as the front speakers when set to 3/2 (not entirely, when a plane fly's over in the vid you still here it behind you but for example dialouge can be heard over all speakers.

Last edited by Desertfox92; 7th May 2009 at 03:16 PM.
Reply With Quote
  #6 (permalink)  
Old 7th May 2009
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Quote:
Originally Posted by Desertfox92 View Post
...Its set to 3/2+SW 5.1 channel
The dolby surround settings seem to do nothing (still FR and LR)
PCM is set as 16bit
SPDIF is disabled
Yes
Yes under Intervideo AC3 (this also has a 5.1 option but does not do anything. ...
Note there cannot be mention of "AC3Filter" under Intervideo AC3 as AC3Filter and IntervideoAC3 simply are two different beasties!
As mentioned under item (6) of my Help2Help-post:
Quote:
(6)... take some time to look at the various possibilities and options of BSPlayer. E.g. rightclick on BSPlayer's control panel and follow the several items (especially also those under "Options"/"Preferences"). (By the way: if you have no Intervideo AC3 installed: just forget about the page with that name under "Audio" as that page indeed only applies to Intervideo AC3 and e.g. not to AC3-filter)
What I asked is whether AC3Filter was shown (with an appropriate file loaded) at "For AC3 decoding use..." under
(rightclick >) Options > Preferences > Audio (south east corner)?
What if you do select "Use SPDIF"?
Did you meanwhile also have a look at the other AC3Filter-settings under its Mixer/Gains/System-tags?
(e.g. under Gains the 'gain' can be set at the level of individual speakers!).

(PS: AGC as referred to by adicoto is "Auto gain control" on Mixer-tag.)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #7 (permalink)  
Old 7th May 2009
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 49
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Can you post here a picture of the matrix used ? I've seen something similar once and solved only by modifyng the matrix. It should have 1 on the diagonal, from L (upper left) to Sub. (lower right) and 0 in rest. Also enable bass redirect.
Reply With Quote
  #8 (permalink)  
Old 7th May 2009
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

adicoto refers to the matrix on Mixer-tag
("Bass redir" is just at the left of it (at bottom))
Attached Images
File Type: png MixerTagMatrix.png (2.1 KB, 7 views)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #9 (permalink)  
Old 8th May 2009
Junior Member
BS.Player Newbie
 
Join Date: May 2009
Posts: 6
Rep Power: 0
Desertfox92 is on a distinguished road
Default

Quote:
Originally Posted by adicoto View Post
Can you post here a picture of the matrix used ? I've seen something similar once and solved only by modifyng the matrix. It should have 1 on the diagonal, from L (upper left) to Sub. (lower right) and 0 in rest. Also enable bass redirect.
I'll be damned, (don't know if I can say this here) I turend on bass redirect, and guess what good quality 5.1 sound!

So far I could only test it on 2 video's 1 with 5.1 ac3 sound (which sounds great with bass redirect) and 1 Saving private tryan 720P sample which still has strange sound but its maby becuase Saving private ryan is in DTS? (I did selected prefer AC3 filter for DTS)

I'll check my other videos when I come back from school.

Edit: checked some other video's they still seemed to have the dialouge problem. How ever I modyfied the matrix a bit (it used to be all 1 from upper left to down right) and by changing voice to -2.5 DB + some other things I finely got good sound, I'm fine tuning it right now. I'll let you know when im done.

Edit: Fine tuning is done, everything sounds normal now, thanks for your help everyone! I appreciate it.

There is how ever 1 problem. I got this dolby surround test which first does your front L C R and the RS (right surround) LS and the first 3 are working fine but when the back speakers are up you hear the sound from the FRONT and BACK speakers? and AC3 filter only shows RS having audio outputted (don't know if thats a word) The movie IS 5.1 dolby surround.

Last edited by Desertfox92; 9th May 2009 at 11:42 AM.
Reply With Quote
Reply

Tags
ac3, filter, sound

Thread Tools
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Sound Problem Atsomething General Talk And Support 10 15th September 2006 01:26 PM
I have a sound problem with BS player. Only video, no sound. jay911 General Talk And Support 8 21st October 2005 07:36 PM
Sound Problem - mpeg2 & mpeg1 General Talk And Support 5 24th September 2004 07:17 AM
SOUND PROBLEM FIXED!!! movieman200x Bug Reports And Codecs 6 20th June 2004 03:58 PM
problem with sound when playing .vob files noonius Bug Reports And Codecs 0 12th July 2002 07:35 PM


All times are GMT +1. The time now is 10:19 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19