Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 9th April 2009
Junior Member
BS.Player Newbie
 
Join Date: Apr 2009
Posts: 4
Rep Power: 0
Downgrrl is on a distinguished road
Default [CONFIRMED] Wrong Decimal Separator in Subtitle Editor

The official format of .srt subtitle files is "The time format used is hours:minutes:seconds,milliseconds, with the milliseconds field precise to three decimal places. The decimal separator used is the comma, since the program was written in France, and the line break used is the CR+LF pair. Subtitles are indexed numerically, starting at 1." (wiki)

I.e. 00:00:00.000 is INCORRECT, even if some players, including Bsplayer recognise either.

The problem is, that the Bsplayer subtitle editor saves to 00:00:00.000 even if fed with 00:00:00,000, which means that players like VLC, which oblige to the correct "," format, no longer accept them; Unless you make serial edits of 0. to 0, etc. afterwards, which is extremely tedious. Earlier versions used to display 00:00:00,000 if fed this, but still save to ".", newer versions just display the (incorrect) "." version and save to it.

Is it possible to convince Bsplayer to use the correct decimal separator? I have searched the options high and low but not found any way of doing this.

The editor itself is very useful for dynamically resyncing subs and changing from sub/idx to srt etc. and I have found this bug annoying for years.
Reply With Quote
  #2 (permalink)  
Old 9th April 2009
Ico-man's Avatar
BS.Support
BS.Player Power User
 
Join Date: Sep 2006
Location: Slovenia
Posts: 1,467
Rep Power: 10
Ico-man is on a distinguished road
Thumbs up

Too bad you didn't report it earlier. Try upcoming version of BS.Player
Reply With Quote
  #3 (permalink)  
Old 9th April 2009
Junior Member
BS.Player Newbie
 
Join Date: Apr 2009
Posts: 4
Rep Power: 0
Downgrrl is on a distinguished road
Default

So on further research, and reading around here it turns out that I can reset my country settings so that the "," is the global system default decimal separator and then the editor both uses and produces comma separation.

The problem is that this is incorrect behaviour.

Though it is a useable quickfix for me, it is annoying as I have to remember to reset it afterwards. It is wrong simply because the separator in .srt files format is fixed, is the comma, and is not country dependent.

So this is a real bug.

For Bsplayer to accept both period or comma separated timestamps is possibly sensible, especially if many people now have files in the incorrect format. To produce the incorrect format is not acceptable.
Reply With Quote
  #4 (permalink)  
Old 9th April 2009
Junior Member
BS.Player Newbie
 
Join Date: Apr 2009
Posts: 4
Rep Power: 0
Downgrrl is on a distinguished road
Default

Quote:
Originally Posted by Ico-man View Post
Too bad you didn't report it earlier. Try upcoming version of BS.Player
Does this mean that you have tracked it as a bug? If so, yes, I will.

I have not reported it earlier because a) I never could be asked to register on the forum to report it b) I never used the editor that much c) by the time I wanted to report it I had fixed the odd file produced with notepad - but mostly because I was usually using Bsplayer, which accepts "wrong" files and thought that videolan was wrong to reject them. I only just got around to checking the specs and investigating. My Bad
Reply With Quote
  #5 (permalink)  
Old 10th April 2009
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 51
Posts: 5,147
Rep Power: 27
adicoto is on a distinguished road
Default

Just loaded an sub file and saved it as srt. No problems, ","it's used. Is it possible that BSPlayer reads OS regional settings and act depending on it ? As there is a decimal separator, it will be used according to OS regional settings, isn't it so ? Rather than the correct usage which says: ","it's used, as the software was developped in France
Reply With Quote
  #6 (permalink)  
Old 10th April 2009
Junior Member
BS.Player Newbie
 
Join Date: Apr 2009
Posts: 4
Rep Power: 0
Downgrrl is on a distinguished road
Default

Quote:
Originally Posted by adicoto View Post
Just loaded an sub file and saved it as srt. No problems, ","it's used. Is it possible that BSPlayer reads OS regional settings and act depending on it ? As there is a decimal separator, it will be used according to OS regional settings, isn't it so ? Rather than the correct usage which says: ","it's used, as the software was developped in France
Yes, it (Bsplayer Pro 2.36.990 subtitle editor) currently uses the default system regional settings, as I already said below.

But this is simply not correct, even if it sometimes produces the correct result. It is true that the comma was chosen for the format because the software and format was developed in France, BUT the format is specified fixed only with the comma, at least up till now.

Thus many players, "correctly", refuse to accept (not accept = not parse properly = no subtitles) the decimal point srt's which result if you use the current Bsplayer editor with a "." as default regional separator. I have my XP set to UK (English) with German Keyboard and it currently produces 00:00:00.000.

Perhaps the .srt format specification should be changed, to allow either "." or ",". I have no idea where that would be done though, and I do not know if all the media players which require a "," would be pleased to simply change their software to accept either. In terms of parseability (eindeutigkeit) either "," or "." would work fine. I do not know if there is an international or internet standard for time stamp formats with decimalised seconds.

I have talked to VLC about this, and they seem to be considering allowing either ("." or ",") in future versions, though I am not involved at their decision level.

SubSync accepts either "." or "," but writes only the correct format ",".
Reply With Quote
  #7 (permalink)  
Old 12th April 2009
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 22
Tizio will become famous soon enough
Default

I think that BS.Player should save the subtitles with the "," (comma) character as decimal separator, independently from the international settings used in the users' OS.

At the moment (BS.Player v2.40.995B) BSplayer still uses international settings.
This is actually a bug, so it have to be fixed

SubRip's specifications can be changed/rewritten, but it's not the preferred solution, and the proper solution is to fix the BSplayer bug instead of changing someone else specifications
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
Reply

Tags
decimal, editor, separator, subtitle, subtitle editor

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
howto use subtitle editor hapciustyle Feature Requests, Feedback And Suggestions 4 29th December 2008 10:27 AM
BUG in Subtitle Editor on BS.Player 2.22 wscientist Bug Reports And Codecs 4 1st August 2007 01:00 PM
Subtitle editor in the BSplayer menus Meserschmit General Talk And Support 10 24th July 2005 08:05 PM
Subtitle Editor: decimal comma bug XelaG Bug Reports And Codecs 0 14th December 2004 12:35 PM
(Pro) Subtitle Editor suggestions XelaG Feature Requests, Feedback And Suggestions 7 4th October 2004 05:40 PM


All times are GMT +1. The time now is 09:10 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19