Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 7th August 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Arrow Bugs/cosmetical issues re GUI/translation of BS.Player versions 256.1043-258.1056β

Bugs or cosmetical issues re GUI/translation of BS.Player versions 256.1043 till 258.1056β
If any of the issues mentioned below is fixed in a certain build, they will be "greyed out" (with a possible green comment).

(1)
A really extensive list of music genres is now in translation file for 'properties'.

However, apparently there is no (inter)connection with the 'Genre-list' used for main "ML-Audio-window"
(see the very bottom-left corner of picture above; disregard the red marking and arrow!!).
Ditto for 'Genre-list' Radio.
Further: however extensive, the list will almost never be complete for local use in several countries. (Like e.g. in The Netherlands we've got "Nederpop", "Levenslied" and "Nederhop" and "Piratenmuziek".)
Maybe it's an idea to have a(n additional) user-defined list (instead)?
Also see BG's post on this subject !

(2)
lang_changes.txt doesn't mention (for changes v2.54.1036 -> v2.54.1037) that the added lines are for [WID17];
(I personally also added another line to 136H: "Doesn't work if the option 'Transparent background' is selected")

(3)
No translation (not in translation file) for:
[Error]
Can't save configuration file!
Please reinstall with defaults settings or choose folder with
write permission.

(4)
No translation (not in translation file) for:
[BS.Player]
This BETA is more than two months old.
Please download updated version from www.bsplayer.com
(noticed this in an older Free beta version)

(5)
Concerning Media Library window:
I would prefer the (wider) width for the scrolling title of this window, as e.g. in beta 2.54.1041 / 201007201504 (or in this v.2.52; don't be distracted by the red colored notes) !!
Width for title restored in version 2.57.1044β

(6)
Reported by BG's:
Quote:
Originally Posted by BG's View Post
When using the option Menu -> Subtitles -> Upload subtitles untranslated text "Please wait..." appears though this string exists in lang file.
Quote:
Originally Posted by BG's View Post
I noticed untranslated pop-up help on the right hand side tab menu...
(fixed in version 2.57.1049 of 30-Nov-2010)
and when you are clicking on that icon (i.e. "Repeat mode") another untranslated message ("Press R to mark A") appears on the main window.
BSPeter note: ditto as above for Audio-tag!

(7)
Added 12-Nov-10 see below (not in language file):



(8)
Added 17-Nov-10
Quote:
Originally Posted by BSPeter View Post
In BS.Player 2.57.1047β (201011161215) new features were introduced, i.e. ...
(1) ... an option to change background color for full screen mode.
However the text "Video background color" is not in the language file! (Also see Edit for version 2.57.1049below)
(2) ... (Edit: item (2) replaced by (9) below)
Edit for version 2.57.1049 of 30-Nov:
Text "Video background colour" still isn't mentioned in file "lang_changes.txt" nor in the English language file.
However translators can add it under
[WID10]
133=Video background colour (Fixed in version 2.57.1050 of 06-Dec-2010)

(9)
Added 19-Nov-10:
(Suggested change of (label)texts. Why? See thread below.)
"OSD sample" isn't really an example of how OSD looks like.
E.g. the selected background colour isn't even reflected in this "example".
In fact it hasn't done so for an awfull long time already; the last version which I still have installed which really shows the selected background colour, is version 0.86 !!!!
At present this "example" also doesn't show when "new OSD mode" is selected (text within frame with background) either.
So the "OSD sample" in reality is nothing more and nothing less than an "OSD font sample" !

(The part with the light green markings solved by amended coding resp. helptext in build 1049 of 30-Nov-2010 resp. build 1050 of 06-Dec-2010)

(10)
Added 08-Dec-10:
When using "Custom position" for subtitles ....
... with old parser/renderer the sample-text moves with pointer.
... with new engine, it doesn't. (Sample text fixed at left/middle.)
(The OSD-info states correct pointer (=subtitle) position.)

Maybe in this connection also see this bugs-report by black_ps: http://forum.bsplayer.com/bug-report...html#post43507

(11)
Added 20-Aug-11:
As a PS to item (10): moreover the text "Subtitle Sample" is not in translation file.
Further ....
under rightclick > Subtitles > Check for subtitles on-line
no translation (not in translation file) for:
"All"


(My previous post on BS.Player 252-253-254-bugs re GUI/translation" can be found overhere)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #2 (permalink)  
Old 25th August 2010
BG's's Avatar
Member
BS.player Regular User
 
Join Date: Mar 2005
Location: Bulgaria
Posts: 53
Rep Power: 0
BG's is an unknown quantity at this point
Default

1) When I click RADIO or TV, a Media Library window opens and non-existing main window "(sub-)menu" appears.




Edit BSPeter:
I cannot confirm the above behaviour;
the greyish areas (1 resp. 2 'columns') marked above with red questionmarks don't show overhere;
instead the right hand side tabs remain attached directly to the main (blue) window (like they should).

2) Pop-up help on right-hand side tabs (VIDEO, DVD, AUDIO, RADIO, TV) is not translated.
Reply With Quote
  #3 (permalink)  
Old 12th November 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Further untranslated texts:
Attached Images
File Type: jpg ErrorAndSendAssistant.jpg (21.3 KB, 1 views)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #4 (permalink)  
Old 17th November 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

In BS.Player 2.57.1047β (201011161215) new features were introduced, i.e. ...
(1) ... an option to change background color for full screen mode.
However the text "Video background color" is not in the language file!
(2) ... a new OSD mode.
However, it appears that the users' options under OSD preferences "Use new OSD mode" and "Transparent" do not go together (as the new OSD mode always has a solid background). Consequently selection of one should automatically deselect the other.

Further IMHO this second new feature makes it even more necessary to change the text "OSD sample" into "OSD font sample". (I've done so in my translation.)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #5 (permalink)  
Old 17th November 2010
Ico-man's Avatar
BS.Support
BS.Player Power User
 
Join Date: Sep 2006
Location: Slovenia
Posts: 1,425
Rep Power: 10
Ico-man is on a distinguished road
Default New OSD mode

Transparent new OSD mode will work only in W7/Vista (with EVR renderer), otherwise, in all other combinations of OS and video renderers, OSD background will be solid color.
New OSD mode is enabled by default only in W7.

"Video background color" should now be in lang changes file.
Reply With Quote
  #6 (permalink)  
Old 17th November 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Quote:
Originally Posted by Ico-man View Post
Transparent new OSD mode will work only in W7/Vista (with EVR renderer), otherwise, in all other combinations of OS and video renderers, OSD background will be solid color.
New OSD mode is enabled by default only in W7.
So maybe a "H-text" in the language file to this effect would be appropriate?
Quote:
Originally Posted by Ico-man View Post
"Video background color" should now be in lang changes file.
I agree, it should. But it isn't!! (checked again a minute ago); that's exactly why I report it! If you want me to stop doing so, just say so!
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #7 (permalink)  
Old 18th November 2010
Ico-man's Avatar
BS.Support
BS.Player Power User
 
Join Date: Sep 2006
Location: Slovenia
Posts: 1,425
Rep Power: 10
Ico-man is on a distinguished road
Default

Correction: Transparency will work only in old OSD mode, but you can still make new OSD mode translucent by using OSD Alpha blending setting.
We will fix settings accordingly in next version.

Alpha blending setting will work only with EVR in VMR video renderers (not overlays).

TV and Radio button opening right side menu bug will be fixed in next version.
Reply With Quote
  #8 (permalink)  
Old 18th November 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

So it appears that my earlier statement "Use new OSD mode" and "Transparent" do not go together is correct after all. So selection of one should indeed automatically deselect the other. (Note: on the other hand deselection of one should not automatically select the other.)

(Maybe we should re-think the option-'labels' to make these more 'transparent'; maybe I'll come up with a suggestion later.)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #9 (permalink)  
Old 19th November 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

I think if label-texts are changed as below, contrary to what I said previously no changes in the code need to be made as it is obvious that "No background in old OSD-mode" doesn't apply for new mode, whereas also confusion between "Transparent" and translucent (by alpha blending) is avoided:


Note:
"OSD sample" isn't really an example of how OSD looks like.
E.g. the selected background color isn't reflected in this "example".
In fact it hasn't done so for an awfull long time already.
The last version which I still have installed which really shows the selected background colour, is version 0.86 !!!!
At present this "example" also doesn't show when "new OSD mode" is selected (text within frame with background) either.
So the "OSD sample" in reality is nothing more and nothing less than an "OSD font sample" !
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #10 (permalink)  
Old 2nd December 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

In version 2.57.1049 regretfully the file 'lang_changes.txt' nor the English language file have been updated (still concern 2.57.1046).

However translators should know that at least one addition should be made for version 2.57.1049 under
//Preferences, Video
[WID10]
i.e.:
133=Video background colour
(I already put it in my Dutch language file)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #11 (permalink)  
Old 4th December 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default Custom position using new subtitle engine

With new subtitle engine when using "custom position" the text "Sample subtitle" doesn't stick to and move with mouse cursor. The text remains at the same position. The position where clicked with the mouse pointer sets the subtitle's custom position though!
(XP SP3 - Internal renderer overlay (default))
Using old subtitle engine the text "glues" to the mouse pointer.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #12 (permalink)  
Old 8th December 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Bug still valid for 1050/1051 builds.
With old parser/renderer the sample-text moves with pointer.
With new engine, it doesn't. (Sample text fixed at left/middle.)
The OSD-info states correct pointer (=subtitle) position.

Maybe in this connection also see this bug-report by black_ps: http://forum.bsplayer.com/bug-report...html#post43507
Attached Images
File Type: png SubsSampleText.png (15.4 KB, 0 views)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #13 (permalink)  
Old 20th August 2011
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Under rightclick > Subtitles > Check for subtitles on-line
no translation (not in translation file) for:
"All"
Edit: Solved in version 2.59 build 1060 beta!
Attached Images
File Type: png AllSubsProvidersOK.PNG (6.7 KB, 37 views)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
Reply

Tags
bugs or cosmetical, custom, engine, gui or translation, issues, position, subtitle, version

Thread Tools
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bugs/cosmetical issues re GUI/translation of BS.Player versions 252/253/254 BSPeter Bug Reports And Codecs 19 2nd August 2010 09:15 PM
Bugs/cosmetical issues re GUI/translation of BS.Player (still valid for 2.52.1031) BSPeter Bug Reports And Codecs 21 27th March 2010 03:05 PM
Bugs re GUI/translation of BS.Player VERSION 2.3x BSPeter Bug Reports And Codecs 5 14th October 2008 05:46 PM
BS.Player 2.2x bugs re GUI/translation BSPeter Bug Reports And Codecs 1 26th July 2008 11:40 PM
crashes playing ogm or mkv files aok General Talk And Support 38 28th February 2006 10:58 PM


All times are GMT +1. The time now is 03:57 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19