Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #61 (permalink)  
Old 15th March 2014
Junior Member
BS.player Regular User
 
Join Date: Jan 2009
Posts: 20
Rep Power: 0
SolidSnake916 is an unknown quantity at this point
Default

Version 2.56 Build 1043 Confirmed to work, the Video freeze, while audio plays with infinite ERROR Sound that lags computer is not present with this.

Last Error Log: Pastebin
K-Lite Mega Codec Pack is being used, With these various settings tweaks

Filter Management > Allow Intermediate Filters [Checked] (Allows K-Lite Filters to load)
Subtitles > Subtitles Disabled [Checked] (K-Lite Manages this)
Audio > Use Internal Vorbis Decoder [Unchecked] (K-Lite Manages this)
Optional Video - EVR Rendering, this older client doesn't allow MadVR so EVR is the next best thing.

I have tested various situations on my pc, thinking Windows 7 Power Management and Mother Board Programs could be at cause, like Asus AI Suite II, or Digi+ Power Management Control, but none of them were.

I have tested this for 7 hours having each error occur at the 50minute mark, i have successfully played 3 hours worth and no error.

Note the error, doesnt matter how long the files are, i have played 30 minute episodes by just loading them over top, not closing the player and the error happens, but on the version i noted, it never happens.

I believe its something to do with Software / Drivers / Hardware on the pc, and BS player not working well with it. The Error Logs dont say much, i have attached my full error log in a pastebin a few posts back as well.

I will test anything the devs make as i want the best player to be fixed and work smoothly for everyone.

This is the only feedback i can give for now!
Reply With Quote
  #62 (permalink)  
Old 15th March 2014
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 51
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

1. Try to run BSPlayer through rightclick -> run as administrator

2. I know that this can sound stupid, but do you have a default phisical printer installed? If not, can you install one ? (BSPlayer it's written in Delphi and your error it's "Canvas doesn't allow drawing" which seems to be overrided by installing a default printer.)



Don't do the both things at the same time.

LE: after reviewing this post, some of the users that reported this issue seems to have solved this problem by re-registering quartz.dll. Can you also test this ?
Reply With Quote
  #63 (permalink)  
Old 15th March 2014
Junior Member
BS.player Regular User
 
Join Date: Jan 2009
Posts: 20
Rep Power: 0
SolidSnake916 is an unknown quantity at this point
Default

Adicoto i cant run it as Administrator, because UAC is off, so it technically is already running in Administrator, unless the developers rely on UAC then i can see a major issue.

I will try the printer thing later.

I am now testing the re-register of quartz in both locations.

run > %windir%\system32\regsvr32 %windir%\SysWOW64\quartz.dll
run > %windir%\system32\regsvr32 %windir%\system32\quartz.dll

Will report back if fixed
Reply With Quote
  #64 (permalink)  
Old 15th March 2014
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 51
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

Quote:
Originally Posted by SolidSnake916 View Post
Adicoto i cant run it as Administrator, because UAC is off, so it technically is already running in Administrator, unless the developers rely on UAC then i can see a major issue.
Unknown are the ways of the Windows
Reply With Quote
  #65 (permalink)  
Old 15th March 2014
Junior Member
BS.player Regular User
 
Join Date: Jan 2009
Posts: 20
Rep Power: 0
SolidSnake916 is an unknown quantity at this point
Default

Re-Registering Quartz.dll did not fix it, moving onto Printer, but i doubt that will fix. It probably has something to do With UAC or Quartz like the poster 1337inside Posted.

Bare with me that i didnt restart my pc, because when registering .dlls its done instantaneous and should not matter if restart occurs.

Will report back after Printer Setup.
Reply With Quote
  #66 (permalink)  
Old 15th March 2014
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 51
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

quartz.dll is the core of directshow (part of DirectX) and contains part of the filters used to decode streams. And BSPlayer it's a player based on DirectShow.
Could you render a file in GraphEdit and post the filters ?
Reply With Quote
  #67 (permalink)  
Old 16th March 2014
Junior Member
BS.player Regular User
 
Join Date: Jan 2009
Posts: 20
Rep Power: 0
SolidSnake916 is an unknown quantity at this point
Default

Quote:
Originally Posted by adicoto View Post
quartz.dll is the core of directshow (part of DirectX) and contains part of the filters used to decode streams. And BSPlayer it's a player based on DirectShow.
Could you render a file in GraphEdit and post the filters ?
Explain how to do this, and i'll proceed with testing, do you have skype or teamspeak as i can do this live with you.

Installed Printer, didn't solve anything.

This error is very tricky... As it is still happening!

Major Edit: All older Versions will no longer load any video files and crash

What lead up to this Installed printer, did system updates, system changed into Japanese Locale, Video Card Updates.

I have reinstalled K-Lite and BS Player versions to try and get it to work, no luck, the version i said didn't have the issue for 1 hour crash wont even load anything, it hangs on loading a file...

Last edited by SolidSnake916; 16th March 2014 at 07:45 AM.
Reply With Quote
  #68 (permalink)  
Old 16th March 2014
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 51
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

Download GraphEdit from here:

GraphEdit 10 090704 - VideoHelp Downloads

it's a free download. Microsoft's software.
Open the file, do a printscreen and post.
Reply With Quote
  #69 (permalink)  
Old 16th March 2014
Junior Member
BS.player Regular User
 
Join Date: Jan 2009
Posts: 20
Rep Power: 0
SolidSnake916 is an unknown quantity at this point
Default

Read my previous post as i have edited it, here's the screenshot from graphEdit

http://i59.tinypic.com/2csgqrn.png
Reply With Quote
  #70 (permalink)  
Old 16th March 2014
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 51
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

Open BSPlayer, swich rendering methode in video options, close BSPlayer, open a file. Swich back to EVR.
Reply With Quote
  #71 (permalink)  
Old 16th March 2014
Junior Member
BS.player Regular User
 
Join Date: Jan 2009
Posts: 20
Rep Power: 0
SolidSnake916 is an unknown quantity at this point
Default

is this to test the 1 hour crash? or the program not opening any video files on older versions.

Edit: Testes this on new version before and still crashed, just tested to play on old version and still hangs, LAV Audio never loads and it just freezes and i need to ctl+alt+delete to close it.
Reply With Quote
  #72 (permalink)  
Old 16th March 2014
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 51
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

It was to solve the new problem, not the one hour crash. Probably after re-registerig quartz.dll, LAV filters lost association.

So, from codec pack you installed only LAV filters or ffdshow too ?
Reply With Quote
  #73 (permalink)  
Old 16th March 2014
Junior Member
BS.player Regular User
 
Join Date: Jan 2009
Posts: 20
Rep Power: 0
SolidSnake916 is an unknown quantity at this point
Default

I reinstalled the entire K-Lite Coded Pack, im going to try a restart again. After reinstalling it.

No ffdshow, its inferior to LAV.

EDIT: Did not work! Man i hate windows so much!!!

Last edited by SolidSnake916; 16th March 2014 at 04:21 PM.
Reply With Quote
  #74 (permalink)  
Old 18th March 2014
Junior Member
BS.player Regular User
 
Join Date: Jan 2009
Posts: 20
Rep Power: 0
SolidSnake916 is an unknown quantity at this point
Default

Still having freeze/lag/crash after 50 minutes.
Reply With Quote
  #75 (permalink)  
Old 31st March 2014
Junior Member
BS.player Regular User
 
Join Date: Jan 2009
Posts: 20
Rep Power: 0
SolidSnake916 is an unknown quantity at this point
Default

Since it seems support has stopped and the Developers have no idea or care about this issue, i have stopped caring about this application after using it for 4 years. i have now went to other player. Until this Company decides its customers matter i wont be back.
Reply With Quote
  #76 (permalink)  
Old 21st June 2014
Junior Member
BS.Player Newbie
 
Join Date: Feb 2014
Posts: 9
Rep Power: 0
whotheff is on a distinguished road
Default

Bug still exists in 2.67
Reply With Quote
  #77 (permalink)  
Old 21st June 2014
Junior Member
BS.Player Newbie
 
Join Date: Feb 2014
Posts: 9
Rep Power: 0
whotheff is on a distinguished road
Default

Forgot to mention: if you seek forward/backward using keyboard arrows the bug happens more often, but always after 60% of the movie
Reply With Quote
  #78 (permalink)  
Old 25th June 2014
Junior Member
BS.Player Newbie
 
Join Date: Jun 2014
Age: 27
Posts: 2
Rep Power: 0
Vorador is on a distinguished road
Default i guess no1 read my reply on the other thread :(

so.....i guess no1 read what i posted on the other thread.......like i said i had the same problem bs crash image froze while sound still playing normaly and windows gave critical error (after 1hour more or less) i changed theme for windows to classic not on an aero theme....and the problem stoped its more than a week now that bs working perfect for me (also i changed back to an aero theme and the problem didn apear again) dont know why or how (i had this problem for more than a year)....like i explained to the other thread i dont know much adout video player or codecs etc.....i hope i helped some1 understand what might cause the problem.....and somethink last i dint change or upade any codec or bs player the only thing i did was change the theme to classic and the problem fixed


my pc has windows 7 ultimate 64 - bs version 2.65 build 1074
Reply With Quote
  #79 (permalink)  
Old 11th July 2014
Junior Member
BS.Player Newbie
 
Join Date: Feb 2014
Posts: 9
Rep Power: 0
whotheff is on a distinguished road
Default

I'll try switching to clasic and back to aero then, i hope you're right!
Reply With Quote
  #80 (permalink)  
Old 1st September 2014
Junior Member
BS.player Regular User
 
Join Date: Jul 2009
Posts: 19
Rep Power: 0
burekas is on a distinguished road
Default

Quote:
Originally Posted by Vorador View Post
so.....i guess no1 read what i posted on the other thread.......like i said i had the same problem bs crash image froze while sound still playing normaly and windows gave critical error (after 1hour more or less) i changed theme for windows to classic not on an aero theme....and the problem stoped its more than a week now that bs working perfect for me (also i changed back to an aero theme and the problem didn apear again) dont know why or how (i had this problem for more than a year)....like i explained to the other thread i dont know much adout video player or codecs etc.....i hope i helped some1 understand what might cause the problem.....and somethink last i dint change or upade any codec or bs player the only thing i did was change the theme to classic and the problem fixed


my pc has windows 7 ultimate 64 - bs version 2.65 build 1074
It's not helps :/
It increase when you move back\forward with the arrow keys or make some pause breaks.

Which other software do you recommand so we can use it instead BSPlayer? Meanwhile I moved to VLC Player.

Last edited by burekas; 5th September 2014 at 02:08 PM.
Reply With Quote
Reply

Tags
abaut, crash

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
Crash at the end of the video under Vista dcsteph1538 Bug Reports And Codecs 4 11th November 2008 11:57 AM
crash on loading mpg files (Free build 1.22 (b817)) rgann General Talk And Support 3 17th April 2005 10:19 PM
1.00.810: Crash playing ogm-files the_doctor Bug Reports And Codecs 0 6th September 2004 08:42 PM
crash with play list lemoineo Bug Reports And Codecs 0 3rd December 2002 07:37 PM
Weird crash 0.85.490 LOC Bug Reports And Codecs 0 4th August 2002 06:04 PM


All times are GMT +1. The time now is 12:43 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20